0 Replies Latest reply: Mar 1, 2014 1:40 PM by Picoscope
Picoscope Level 1 Level 1 (5 points)

We manage several public event calendars in OS X Server 10.6.8 via a single user called "Calendars" that publishes all its public calendars to the server. To facilitate ease of management in users' iCal, I also created a second user - called "Almanac", to whom I have delegated "read only" access to these calendars via iCal's delegation tab in the "Calendars" account. Thus, most users view the calendars by authenticating iCal using the "Almanac" account, while two or three privledged calendar managers view and edit that same data by authenticaing using the "Calendars" account.

 

This worked flawlessly for years, until recently when for no apparent reason, the "Calendars" account was getting automatically disabled on the Server, causing authentication errors in users' ical and of course presenting event updates. At first I thought the fault lay in my OD policies, which are set to delete accounts after 90 days of inactivity. However, this particular account has been excepted from this policy in Workgroup Manager via the Avanced Tab/Options.

 

In the past, I've cleared up similar niggling problems by simply deleting and recreating the problematic user account, making sure to use the same short name and then running chown -r on the appropriate user home folder.  I did that with this account, and indeed it is no longer being disabled. However, all of the precious iCal calendar events have disappeared. I can see the calendars themselves when I log into the Calendars user account and start up iCal, but there are no events present. When I try to access the calendars on the server via a privledged or unprivledged user in iCal, I get the message:

 

"The calendar http://<my.server.FQDN>:8008/principals/__uids__/00C48532-BA77-478C-A4D3-17A848DD9F6D/ was not found on the server. Make sure the URL is correct."

 

Looking at the Calendar user home folder, it looks like the data is all still there in ~/Library/Calendars. On the server, I also see what appears to be the Calendar Server documents that match the above UID in /Library/CalendarServer/Documents/Calendars/_uids_/...  Of course, I also have multiple backup copies of all of these directories via TimeMachine, SuperDuper! and PresSTORE.

 

I've already tried rm all the user calendar cache files and resyncing, also tried trashing all the user iCal preferences. Also tried a full restore of the users home folder via TimeMachine and running chown -r again.

 

Thoughts anyone? Thanks.