8 Replies Latest reply: Mar 22, 2014 10:44 PM by BDAqua
Raymon Level 1 Level 1 (75 points)

I've had my PPC MacG4 for 11 years now and running with OS X 10.4.11 since its inception.  The other day, the Finder would not do Shut Down. Checking my Activity Monitor showed in red "Finder not responding". (No kidding. )  I don't recall ever seeing this before. I probably should have done Force Quit to Relaunch the Finder, if available at that time, which I didn't check. Instead I did a manual shut down. After waiting a minute or so I restarted manually and it has been normal so far. I was logged in a single non-admin. account.

 

I do have DiskWarrior (and have not run it for about a year or two).

 

Also. I can boot-up in my internal back-up drive and repair my primary drive if that addresses the problem. Frankly, after reading a few similar Finder behavior Community discussions, I still don't know how to proceed. 

 

I'm afraid to not do anything since I suspect the problem will again show up. But I have no basis for saying that.

 

Thanks!


G4 933 MHz "2002 Quicksilver", 1.54 GB RAM, two 160 GB HD,, Mac OS X (10.4.11), iLife'06, LaCie d2 burner, 320 GB FreeAgent|Go Portable HD
  • BDAqua Level 10 Level 10 (119,875 points)

    DiskWarrior would be the first thing I'd use.

     

    Open console in Applications>Utilities, check the system log for the date/time of the last problem  & the Startup right after that for clues.

  • Raymon Level 1 Level 1 (75 points)

    Hello, BD.

    We've been busy replacing  kitchen appliances: first the fridge, then the dishwasher, then the range/oven.

     

    But last night I was able to get back to my Finder issue. Before running my trusty DiskWarrior 4.3, I ran Disk Utility after starting up in the BackUP drive to allow repairing the MainDrive. Verify Disk for the MainDrive gave three messages in red: "Invalid directory Item count (it should be 1 instead of 536870913); The volume MainDrive needs to be repaired; and The "Volume needs repair". So I clicked on Repair, and after holding my breath for about several minutes, the result was: "The Volume MainDrive appears OK".  (Before this, I also ran Disk Utility for the BackUp drive with results OK for both Verify Permissions and Verify Disk.) So far, my Finder issue is solved as was an issue with the Safari  not loading.

     

    I decided to run DiskWarrior anyway. In the past, I've hastened the boot-up time for Disk Warrior by booting it up in either one of the Drives as opposed to booting up the DW disc (approx. 10 minutes vs. 40 or so minutes), the last time in May 2012. (I used to do it more frequently.) So I turned off the Energy Saver, quit all applications, logged on to Admin. account, and loaded DW. Graph showed 5% of files out of order (not too bad), but when I clicked on Rebuild, "MainDrive cannot be rebuilt, Disk still in use. Quit all applications, restart with DiskWarrior disc, and try again (error code 2153, 4903)". Have never seen the message before, especially "Disk still in use".

     

    Later today this evening, I plan on running DW again,  rebuilding  the MainDrive directory logged on in the BackUp drive (in root as usual) but turning off the cable modem, which is now connected to an Apple router since last September. (My notes  suggest  I may have been turning off the modem before running DW.) If the Rebuild is refused, I'll boot up in the DW disc and hope for the best.

     

    Any thoughts or advice would be much appreciated. Thanks in advance.

  • Raymon Level 1 Level 1 (75 points)

    Update:

     

    Running DiskWarrior was easier than described above. I was able to run DW from both internal drives/volumes while logged in a non-Admin acct. (with modem on). However, DW stated that both internal drives had original directories so damaged that DW would not allow replacement by new directories. But as I mentioned before (above), Disk Repair from Apple Disk Utility previously had pronounced both drives: "The Volume appears to be OK". So, for now I'm standing pat with these drives which seem to be performing OK for my needs.

     

    My back-up is the following. I updated my cloned FreeAgent 300 MB external firewire drive and then  ran DW on it. The result was "...directory of the disk was successfully rebuilt. I booted up the Clone and found satisfory performance with the Safari browser, the email client, and others.

     

    So I guess "I'm good to go" as of now.

  • BDAqua Level 10 Level 10 (119,875 points)

    Hmmm, howcuriuos on the DW report!???

  • Raymon Level 1 Level 1 (75 points)

    Success!

     

    1. Turned off Energy Saver so the Display and the Drives would not be interrupted. Logging in Admin. and starting up with my BackUp drive, I ran my DiskWarrior 4.3 on my HardDrive. It rebuilt my directory in about 20 minutes, and allowed replacement of the old directory. Most of the damage was in file Permissions. I ran Graph which verified a new perfect directory. DW finished with Repair Permissions and Check All Files/Folders.

     

    2. Same as above, except I started up in the HardDrive so DW could repair the BackUp Drive. No problem building a replacement directory which also was allowed by DW to replace the original directory. Finished as above.

     

    3. Mounted my External 300 GB Firewire drive and checked it with DW. Again rebuilt and replaced the directory as above.

     

    My DiskWarrior should be knighted. I started with Version 3.0.2 in July, 2004.

     

    All's well that ends well.

  • BDAqua Level 10 Level 10 (119,875 points)

    Great to hear, thanks for thereport!

     

    DW is golden, instead of upgradinf, I've outright bought several newer versions!

  • Raymon Level 1 Level 1 (75 points)

    Good idea!   DW 4.3 has done well by my PPC G4 Tiger. But I'll check out the AlSoft website and see what they have for my "legacy" desktop. Historically, the DW prices have always been right.

     

    Have a good evening.

  • BDAqua Level 10 Level 10 (119,875 points)

     

     

    You may hav to contact Alsoft for older versions.