2 Replies Latest reply: Mar 5, 2014 8:16 PM by kmurthi
kmurthi Level 1 Level 1

Dear All,


I have resorted to all the options. I want to access macfiles from windows PC. I trieds out all the options. I went to system preferences> selected "file sharing">selected the folder>selected the user name and password for windows account.


But when i click the macbook on the network from windows pc, it prompts me to enter user name and password. When i do the needful it says denied access. I tried to access macbook from two different windows PC one running XP and the other windows 7. The funny thing is that this access is sometimes allowed "say 10% of the time" using the user name and password and sometimes its not allowed.


Another interesting thing is that i am able to connect to windows PC from Macbook but not the reverse option. Somebody pl suggest a way out.





MacBook Air, Other OS
  • BobHarris Level 6 Level 6

    2 things.


    Under System Preferences -> Sharing -> File Sharing, you need to click on "Options" and enable Share file and folders using "SMB".  SMB is the Windows file sharing protocol.


    The second thing is to make sure that the Mac and your PC are in the same Windows "Workgroup".  System Preferences -> Network -> Advanced -> WINS -> Workgroup.  By default Mac OS X will use "WORKGROUP", and I think this is what Windows uses for home users, however, it could be different and if enabling "SMB" above did not work for you, then it is very possilbe your PC is in a different Windows Workgroup.

  • kmurthi Level 1 Level 1

    i have done all that. Both the systems are in the same "WORKGROUP" folders.


    The peculiar thing is smtms i am able to access the contents of shared folder of Mac but most of the time after i enter d username n passwd the screen just gives the message connecting to......Can this be due to communication issues b/w Mac and windows operating systems. Anyways i am facing lot of problems because of this..Interestingly i can access windows folders easily through MACA system by clicking "GO" and then "CONNECT TO SERVER" path....


    Pl let me knw if anyone has any clue on how to sort this issue.


    Thanks for the earlier message