4 Replies Latest reply: Apr 22, 2014 6:41 PM by benchernif
iglaser Level 1 Level 1 (0 points)

When my machine is on battery power and goes to sleep after 15 minutes ... and then I wake it, my WiFi has disconnected and does not autoaticaly reconnect

 

I have to reselect he SSID

 

This has only started happening since I upgraded to 10.9.2

 

Any ideas ?


MacBook, OS X Mavericks (10.9.2)
  • El Morche Level 1 Level 1 (0 points)

    I did notice this morning that the wifi icon in the system tray remained greyed even though I was connected to the internet. I checked my wife's Macbook Air to see if the same was happening there but it wasn't.

     

    I then discovered your post and checked to see what happened after my macbook went to sleep.

     

    Reconnection to my wifi worked okay and I am glad to see that the wifi icon is now black!

     

    Not much help to you I'm afraid.

  • Linc Davis Level 10 Level 10 (150,650 points)

    Test after taking each of the following steps that you haven't already tried. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved. Make sure the box marked

    Remember networks this computer has joined

    is checked.

    2. Follow the instructions in this support article under the heading

    Symptom: After restarting or waking from sleep, my computer might not connect to the Internet

    3. Reset the PRAM.

    4. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    5. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    6. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    7. Repair permissions on the startup volume.

    8. Turn off Bluetooth and test.

    9. Reset the System Management Controller.

    10. Reinstall OS X.

  • iglaser Level 1 Level 1 (0 points)

    Thanks so much

     

    I reset the PRAM and the SMC...and its back to normal now

     

    :-)

     

    Ivan

  • benchernif Level 1 Level 1 (0 points)

    Had this issue after migrating from a 13" 2012 MBA to a 2013 13" rMBP - it really was the only issue that I was having after cloning the data over the Thunderbolt port.  But it's also a very annoying issue everytime you open the lid from sleep.

     

    I removed all my saved networks from the network options, reset the SMC and PRAM, now it's working fine.

     

    Thanks!

     

    Ben