11 Replies Latest reply: Mar 4, 2014 6:18 AM by quiplix
quiplix Level 1 Level 1 (0 points)

I'm having trouble with a singular weirdness: when I type http://www.zen-cart.com into my browser it resolves to 127.0.0.1

  • If I type any subsections of the site such as http://www.zen-cart.com/plugins it resolves properly. This is the only site that has this problem.
  • Network Utility correctly resolves the IP of the site
  • I have a home network with a Mavericks Server running a DNS.
  • Browsers on other machines on the network also exhibit the problem.
  • If I remove the server from my DNS list in the network preferences, the problem persists

 

I've spent some fruitless time trying to find where the the dns value is stored but haven't succeeded.

 

Any suggestions as to how to identify and correct this problem?


OS X Mountain Lion (10.8.5)
  • Camelot Level 8 Level 8 (46,120 points)

    I'm not (yet) convinced this is a DNS problem, although I'm unsure as to what you mean by "it resolves to 127.0.0.1"

     

    In either case, since Network Utility resolves the correct address this implies that DNS is working. Network Utility always performs a fresh lookup (as opposed to relying on DNS cache), so that points away from that.

     

    On the other hand, it's one specific page on one domain - indeed, the fact that sub-pages work also hint that it's not a DNS issue. So the next level in the stack is the browser itself - at first glance this looks like a browser cache problem where the top page of the site has been cached with an error page, whereas other pages are not.

     

    A simple test for this would be to use a different browser, or to clear your browser's cache. Both these opions should pull a fresh copy of the page from the server and may validate the theory.

  • etresoft Level 7 Level 7 (25,625 points)

    It sounds like your DNS server is misconfigured. I tried it once but found it way over my head. Your local machine may be caching the value. Try rebooting it.

  • Linc Davis Level 10 Level 10 (147,070 points)

    Select the Ping tab in Network Utility and enter the server name. Post the output.

  • quiplix Level 1 Level 1 (0 points)

    PING zen-cart.com (75.126.209.10): 56 data bytes

    64 bytes from 75.126.209.10: icmp_seq=0 ttl=45 time=203.581 ms

  • Linc Davis Level 10 Level 10 (147,070 points)

    Nothing is wrong with name resolution.

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, by a peripheral device, by a font conflict, or by corruption of the file system or of certain system caches.

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards, if applicable. Start up in safe mode and log in to the account with the problem. You must hold down the shift key twice: once when you boot, and again when you log in.

    Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a Fusion Drive or a software RAID, you can’t do this. Ask for further instructions.

    Safe mode is much slower to boot and run than normal, with limited graphics performance, and some things won’t work at all, including sound output and Wi-Fi on certain models. The next normal boot may also be somewhat slow.

    The login screen appears even if you usually login automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

    Test while in safe mode. Same problem?

    After testing, reboot as usual (not in safe mode) and verify that you still have the problem. Post the results of the test.

  • quiplix Level 1 Level 1 (0 points)

    ICamelot wrote:

     

    I'm not (yet) convinced this is a DNS problem, although I'm unsure as to what you mean by "it resolves to 127.0.0.1"

    In Safari and via the develop menu I emptied then turned caches off. Typing in "www.zen-cart.com" in the address bar results in a long pause then it eventually replaced by "127.0.0.1"  and this screen:

    Screen Shot 2014-03-04 at 9.48.21 AM.png

     

    Using Firefox gave a similar result

     

    Similarly, my ipad also returns the 127.0.0.1 result.

     

    After turning off dns service in OSX Server, my safari browser still responds with 127.0.0.1 but much more quickly.

     

    Bypassing the server, the HP switch and the Airport router and connecting directly to the cable modem results in proper connection.

     

    I'm intrigued by this since I've rebooted the Airport many times over the past few months - it has a habit of getting sort of slow to connect pads and phones and connecting via the utility shows it "ghosting" - a message pops up telling me "it used to be part of the network and should I forget it?"

     

    Anyway the problem resurfaces when I connect via the Airport ethernet. Does this mean the airport has some form of dns cache too? If so how to purge it. Rebooting doesn't seem to work. The airports DNS is defaulting to the upstream ISP servers.

  • Linc Davis Level 10 Level 10 (147,070 points)

    Back up all data.

     

    From the menu bar, select

      

    System Preferences Network

      

    If the preference pane is locked, click the lock icon in the lower left corner and enter your password to unlock it. Then click the Advanced button and select the Proxies tab. If any proxy options are selected, make a note of them and then deselect them. You don’t need to change the bypass or FTP settings. Click OK and then Apply. Test. The result may be that you can't connect to any web server. Restore the previous settings if that happens.

  • quiplix Level 1 Level 1 (0 points)

    Linc, thanks for the suggestion, tried it twice but it made no appreciable difference.

     

    BTW I tried to access zen-cart.com from the OSX server machine. It also reverted to the loopback address.

     

    Pretty sure all the problems reside with the Airport Extreme now. Just restarted it, according to advice from another thread, aiming to expunge the DNS cache that it harbors. No dice, no luck.

  • Linc Davis Level 10 Level 10 (147,070 points)

    It doesn't have a DNS cache.

  • travisstraub Level 2 Level 2 (175 points)

    Hey quiplix,

     

    I'm not sure if this is relevant, but Clearing The DNS Cache might be something you could try.

  • quiplix Level 1 Level 1 (0 points)

    travisstraub

    In the spirit of "well why not",  I gave your suggestion a whirl.

     

    No dice.