4 Replies Latest reply: Mar 11, 2014 1:07 AM by mjspinks
jcurry10 Level 1 Level 1 (0 points)

I have an HP 8500 Officejet Pro which has airprint.  I have been using it for all of my Apple devices, i.e. iphone, iPad, Macbook pro, Macbook air.  It seems with this last IOS update that I can no longer connect to my printer.  My PC still will print to it wirelessly.  But all of my Apple devices have stopped workng with the printer.  If anyone has any ideas, I would appreciate the help.


MacBook Air, Mac OS X (10.7.2)
  • jason269 Community Specialists Community Specialists (3,800 points)

    Hello, jcurry10. 

     

    Thank you for visiting Apple Support Communities.

     

    I would recommend making sure the printer firmware is updated.  If the issue persists, there are some helpful troubleshooting steps in the article below.

     

    If you are unable to print, or if you see the message "No AirPrint Printers Found"

    Verify that the printer:

    1. Has power and is turned on. If it has power, turn the printer off and then on again to see if that resolves the issue.
    2. Is connected to the same Wi-Fi network as the iOS device.
    3. Has the latest firmware version installed.
    4. Has paper with enough ink or toner installed.
    5. Is free of any errors displayed on the printer's control panel.

    If necessary, consult the printer documentation or contact the printer vendor for help with the above steps.

     

     

    AirPrint Basics

    http://support.apple.com/kb/ht4356

     

    Cheers,

     

    Jason H.

  • jcurry10 Level 1 Level 1 (0 points)

    Thanks for trying to assist in resolving my problem.  However, I am way beyone the basics.  The printer has worked for almost two years with all of my devices and now none of them will print, neither the Mac's nor the Ipads or IPHONES.  My PC does still work however.  Yes, it does have paper, ink, Power, and I have reset the printer several times, I have put it back to factory defaults and verified it has the latest  software, and I have removed it from the network and reinstalled it to the network, yet the problem persists.  I think it is related to the lastest APPLE update but not sure, thats all that has changed.   I was hoping that someone else has seen this problem and knows how to fix it.

     

    Regards,

     

    John

  • H27pinch Level 1 Level 1 (0 points)

    I'm having the same problem. Both of my iPads were able to print after the updates but now they can't see my canon printer. Ink and everything all good, software uninstalled/reinstalled, printer can see the network, on same network but no joy!  Will try canon site to see if they can help.

  • mjspinks Level 1 Level 1 (0 points)

    I am also having the same problem following latest iOS update.  I have tried everything recommended.  My laptop will print if connected via USB but none of my apple devices will find the printer wirelessly.  It is an Epson WF7525 and has worked perfectly for the last year or so from iphone, ipad and imac.  So frustrating. Will try Apple Store today to see if any of the techo guys know why this has happened.