9 Replies Latest reply: Dec 8, 2014 7:55 AM by Richard Schletty
martinafromtexas Level 1 Level 1 (0 points)

I recently moved and had to set up my time machine again.  I am using time capsule with airport express.  Whenever it goes to try to back-up everything, I get the following error message: 

 

The backup disk image “/Volumes/Kelley Huston's Time Capsul/Kelley Huston's Imac.sparsebundle" is already in use

 

Can anyone help me out?  Thanks so much in advance


iMac, Mac OS X (10.7.5)
  • Klaus1 Level 8 Level 8 (45,355 points)

    Sparsebundle already in use:

     

    http://pondini.org/TM/C12.html

  • JGMango Level 1 Level 1 (0 points)

    The above no longer works as you can't install that version of Airport Utility on Mavricks

     

    This is a NAS (in my case Synology error) where the session does not disconnect properly at the end of a back-up

     

    All you need to do is find the current user sessions and kill all active connections. Then restart Time Machine and it will work fine.

  • Evski Level 1 Level 1 (30 points)

    That sounds great but can you help us noob's do that?

    Two questions

    1) How do you identify current sessions and kill them and

    2) What causes incorrect disconnects? I haves been running a NAS fine for 9 months now all sorts of problems with this.

     

    Cheers

  • Elsie777 Level 1 Level 1 (0 points)

    Exactly the same here. Did you find an answer?

     

    I've been using a Synology NAS for over a year for my back ups via Time Machine with no problem and now all of sudden I keep getting the message outlined in the OP about the sparsebundle already being in use etc etc and no back ups existing (i.e. latest and oldest = none) even though there there have been lots of backs ups done over time.

     

    I'm also using a Macbook Pro with Mavericks (unfortunately). I've tried closing everything down, I've tried ejecting the remote disk, but no joy although after doing all this I at least got a back up in process but then after about 6 hours it suddenly failed with the same message I was originally getting straight away. I now get the message straight away again. As you rightly say it doesn't seem possible to close down current connections or at least I can't see how via the NAS or Mac with Mavericks.

     

    BTW As well as the message in the OP, I also got this one...“Time Machine completed a verification of your backups. To improve reliability, Time Machine must create a new backup for you.”

     

    I'd contact Synology too but their support takes weeks to respond.

     

    Here's hoping someone has an answer if it's such a common problem...

  • Scott_T Level 1 Level 1 (0 points)

    If your issue is anything like mine then this is how you kill the connection and fix the problem:

     

    1) From another computer connected to your LAN, log into your NAS from a web browser.

    This might be different depending on how you setup your NAS. You probably should have connected to the NAS in order to initially set it up so you know how to do this?

    BTW, if after entering your login details it tells you 'The operation failed' and it hasn't logged you in, just put the curser in the web browser address field and hit enter - some crazy Synology bug that doesn't happen when I connect from Windoze.

     

    2) Once in the NAS you need to kill the 'afp' connection of the Time Machine login.

    If your 'widgets' aren't showing click the widget icon near the top right corner. Under 'connected users' you should see your web-based connection with your username and of the type 'http' - DON'T KILL THIS ONE Hopefully you'll see an 'afp' connection that is the Time Machine connection with that users account name with it. Click on the red negative symbol and then agree to kill the connection.

     

    3) Tell Time machine to do a backup now and hopefully it all works.

     

    Occasionally the Synology will not let go of the backup and you will have to repeat this. As long as that 'afp' connection remains the backup shows as in use and Time Machine cannot access it.

     

    Good luck.

     

    S.

  • Elsie777 Level 1 Level 1 (0 points)

    Thanks for the reply Scott. That is the solution I used in the end. The only thing I would add is I didn't know where to go to kill the connection originally (and didnt realise 'AFP' was the one to aim for as I had lots of different ones showing so killed them all). I eventually discovered you had to go to the 'Resource Monitor' section on the NAS Home Page, and it can be found within there. Hope this helps someone else as it's a pain.

  • lenayres Level 1 Level 1 (0 points)

    Thanks to Elsie777 for making this more clear.  I would never have found the Resource Monitor widget on my Synology NAS....rarely used, because the unit works so well.

  • domisolfr Level 1 Level 1 (0 points)

    What I do is log to DSM, Control Panel, File services, Mac File Service, then unckeck "Enable Mac file service", and Apply.

    Then I check back "Enable Mac file service", and Apply again.

  • Richard Schletty Level 1 Level 1 (10 points)

    This happened to me and I am glad I found the fix here.

     

    'Resource Monitor' in the Synology NAS main menu (upper left corner) is more helpful in identifying the connection which needs to be killed. It lists user, IP address and resource in wide columns (unlike the stingy widget). It will actually list Time Machine as the resource. You can kill the connection from  this Resource Monitor, as noted above.

     

    I want to know why the Synology NAS won't let go of the connection automatically. I suppose it has to do with a sudden disconnection (such as taking my MacBook to the coffee shop). The NAS connection should time out after a few hours if there is no live AFP connection.