2 Replies Latest reply: Mar 6, 2014 7:12 PM by Allan Eckert
hammer1000 Level 1 Level 1 (0 points)

I have OS x 10.6.8 but I apparently need OS x 10.7.5 to run airport utility software for a new airport extreme. Can I just download the OS X 10.7.5 update or do I need to install OS X lion first and then the 10.7.5 update?