3 Replies Latest reply: Mar 11, 2014 1:25 PM by braden85
jambrose31 Level 1 Level 1 (0 points)

I have a USA iPhone 5s with IOS 7.0.6 and am currently in the UK. I am strictly using wifi and have been using iMessage to communicate with friends and family at home. All of a sudden, my phone stopped sending iMessages with my phone number. I've looked through numerous other threads and all of their suggestions didn't work for me. I was thinking maybe I need to deactivate airplane mode and use data for a small amount of time in order for the phone to re-recognize my number, but I'd prefer not to use cellular data at all because of the roaming charges. If anyone has any idea what to do, please let me know!


iPhone 5s, iOS 7.0.6
  • braden85 Community Specialists Community Specialists (3,620 points)

    Hey jambrose31!

     

    Make sure your phone number is shown in your Messages settings:

     

    iOS: Using Messages

    https://support.apple.com/kb/HT3529

     

    How can I use my iPhone telephone number with iMessage on my iPad, iPod touch, or Messages for Mac?

    You can link your iPhone telephone number to your Apple ID for use on your iPad, iPod touch, or Messages for Mac by signing into iMessage with your Apple ID in Settings > Messages. Then sign in to the other device with the same Apple ID in these locations:

    • iPad and iPod touch: sign in to iMessage in Settings > Messages.
    • Messages for Mac: sign in to iMessage in Messages > Preferences > Accounts.

    Linking your iPhone telephone number with iMessage is not available for the iPad (1st generation) and iPod touch (3rd generation).

    Follow these steps for more information or if you are experiencing difficulties linking your iPhone telephone number to your Apple ID.

    If an unknown device registers with your Apple ID and you did not initiate that registration, you can reset your Apple ID password to remove it. You will then need to enter this new password on all devices using iMessage or FaceTime.

    Additional Information

    You can change the address that new iMessage conversations are started with in Settings > Messages > Send & Receive > Start new conversations from. Note that this setting applies only to new conversations. If you would like to change the address from which messages are sent, first change this setting, and then delete the existing conversation and start a new one.

    iMessage responses will be sent from the address the recipient most recently messaged. For example, a friend sends you a message to your Apple ID. Responses in this conversation will be sent from your Apple ID, even if you've selected new conversations to start from your phone number.

    * Cellular data connectivity requires iPhone or iPad (Cellular Models).

    Thanks for being a part of the Apple Support Communities!

     

    Regards,

    Braden

  • jambrose31 Level 1 Level 1 (0 points)

    Braden,

     

    My issue is that when I go to settings > messages > send & receive, my phone number is shown greyed out. It won't let me select my phone as an option. I signed out of my Apple ID for iMessage and signed back in. It showed my number to be checked, but when I pressed save, it unchecked my number and wouldn't let me use it for iMessage. I tried using the links you sent me, but nothing fixed it.

  • braden85 Community Specialists Community Specialists (3,620 points)

    Hi again jambrose31,

     

    Thank you for using the Apple Support Community. Due to the nature of your issue or question you may find more information by using another one of Apple's support resources - https://getsupport.apple.com/GetproductgroupList.action.

     

     

    Cheers,

    Braden