3 Replies Latest reply: Mar 10, 2014 1:30 PM by John Blanchard1
kareldc2 Level 1 Level 1 (0 points)

I have an HP7900 series printer which worked perfectly under 10.8.

 

Now all of a suddend there is a new driver installed and I don't have any printing options anymore. Can't even choose B&W for gods sake.

 

And the print quality severely dropped! Everthing looks like sh*t!

 

Why is this?

 

Can I install the previous drivers?

 

Where should I look for them?

 

Seriously smells like Apple and HP are tryign to sell more printers!

 

Suggestions more then welcome!

 

Regards,

Karel.


MacBook Pro with Retina display, OS X Mavericks (10.9.2)
  • John Blanchard1 Level 5 Level 5 (5,030 points)

    What driver is installed? 2.0.3 is the current version according to http://support.apple.com/kb/HT3669.

     

    Are you using the extended print dialog? Hide Details should be showing if you are.

  • kareldc2 Level 1 Level 1 (0 points)

    I cannot seem to download or install the latest driver through the HP website. It just guides you to do the apple update process.

     

    This is what is listed under system report:

     

    hp photosmart 7900 series:

     

      Status:     Offline

      Print Server:     Local

      Driver Version:     1.5

      Default:     Yes

      Shared:     Yes

      URI:     usb://hp/photosmart%207900%20series?serial=CN37I1225DER

      PPD:     Generic PCL Laser Printer

      PPD File Version:     1.5

      PostScript Version:     (3010.000) 0

      CUPS Version:     1.7.1 (cups-372.2)

      Scanning support:     No

      Printer Commands:     none

      CUPS filters:

    rastertohp:

      Path:     rastertohp

      Permissions:     ---------

      Fax support:     No

      PDEs:

  • John Blanchard1 Level 5 Level 5 (5,030 points)

    Did you try Software Update?

     

    You're using a PCL driver, so that explains why you're not getting the printing options.

     

    You can download the drivers here: http://support.apple.com/kb/DL907

     

    If you did a clean install, that would explain why the drivers are missing.