8 Replies Latest reply: Mar 16, 2014 7:27 AM by Linc Davis
vinayakdshenoy Level 1 Level 1 (0 points)

Hi there,

 

I recently bought my first Apple notebook - a 15 inch Macbook Pro running OS-X Mavericks. I am running Safari 7.0.2 and am new to Safari. I find that the "Reopened Last Closed Window" option is greyed out. I have searched online communities and deleted plists and rebooted my machine; nothing gives unfortunately.

 

Please could you help?

 

Thanks,

Vinayak


MacBook Pro (Retina, 15-inch, Late 2013), OS X Mavericks (10.9.2)
  • Linc Davis Level 10 Level 10 (160,165 points)

    Open a window, load any web page, and then close the window. Is the menu item still grayed out?

  • vinayakdshenoy Level 1 Level 1 (0 points)

    Hi Linc,

     

    Thank you so much for devoting time to this!

     

    Yes, that option under the History tab, viz: Reopen Last Opened Window is always greyed out.

     

    Regards,

    Vinayak

  • vinayakdshenoy Level 1 Level 1 (0 points)

    In addition, there was a similar thread on about this:

    https://discussions.apple.com/message/9875084#9875084

     

    which ended inconclusively. Now, I don't want to install Glims etc., and working in Support myself, I'd like to help Apple fix the problem.

     

    Regards,

    Vinayak

  • Linc Davis Level 10 Level 10 (160,165 points)

    From the Safari menu bar, select

            

    Safari Preferences... Extensions

         

    Turn all extensions OFF and test. If the problem is resolved, turn extensions back ON and then disable them one or a few at a time until you find the culprit.

  • vinayakdshenoy Level 1 Level 1 (0 points)

    Hi Linc,

     

    Thanks for the quick reply. I don't have any extensions installed on Safari yet. I however, still tried what you told me to, and it hasn't helped.

     

    Really appreciate your assistance here!

     

    Regards,

    Vinayak

  • Linc Davis Level 10 Level 10 (160,165 points)

    Please read this whole message before doing anything.
      
    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
       
    The purpose of this test is to determine whether the problem is localized to your user account. Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”
       
    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.
       
    Test while logged in as Guest. Same problem?
         
    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.
      
    *Note: If you’ve activated “Find My Mac” or FileVault in OS X 10.7 or later, then you can’t enable the Guest account. The "Guest User" login created by "Find My Mac" is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

  • vinayakdshenoy Level 1 Level 1 (0 points)

    Hi Linc!

     

    You did it buddy!

     

    I merely signed in via guest and signed out... Suddenly, Command+Z started working! Also, that option is now available under the History tab in Safari!

     

    Please could you explain how you got to the solution? Currently, to an Apple noob like me, it seems bizarre that a Guest login could release a Safari feature running in Administrator login.

     

    Thanks for your time once again!

     

    Sincerely,

    Vinayak

  • Linc Davis Level 10 Level 10 (160,165 points)

    I don't have the slightest idea.