4 Replies Latest reply: Mar 15, 2014 4:28 PM by wooglin7
wooglin7 Level 1 Level 1 (10 points)

When I start typing my Exchange email address on any web form in Safari, once I type the @ symbol Safari completes the rest of the email address automatically.... but its wrong.  It tacks on some more characters at the end that I always have to delete.  To be clear this does not appear to have anything to do with Autofill settings (the drop down box that appears when typing in a form).


This appears to be a Safari problem, it does not happen in Chrome.  Also, it only happens with one email address and always when I type the @ symbol.  I can't figure out how to fix this and it is beyond annoying!  Anyone had this issue?  I am on Mavericks.



MacBook Pro with Retina display, OS X Mavericks (10.9.2)
  • BenZamora Level 1 Level 1 (40 points)

    I understand it's not the Autofill settings, but try going to Safari > Preferences > AutoFill > Edit... (next to User names and passwords) and look for the e-mail or extra-characters Safari autofills in the middle column (User names), then delete it.

  • wooglin7 Level 1 Level 1 (10 points)

    Thanks for the reply.  I have looked through these settings already and it is not the Autofill settings and it is not specific to any one webpage which those settings adjust.  It does it on all pages if I type the first part the email then the @ symbol.  Bizarre and very frustrating.

  • wooglin7 Level 1 Level 1 (10 points)

    Upon further review, this is not only a Safari issue.  It happens in other applications as well.... in the body of an Outlook email, Reminders, TextEdit, etc, etc.  What the heck!

  • wooglin7 Level 1 Level 1 (10 points)

    Problem solved!  A long time ago I had tried to setup a keyboard shortcut to fill in my email address on my iPhone.  You know when you type 'btw' and it automatically changes it to 'by the way'...  I tried to setup something like this to autocomplete my long email address so I didnt have to tap it out all the time on my phone.  This was well before I bought my Macbook. 


    I just checked my Keyboard preferences on the Macbook and this old text shortcut was in there.  I deleted it and problem solved.  Well it never worked right anyway, I had a 'dot' in there that I think screwed it up.  I just tested a new shortcut without a 'dot' and it works as it should.