3 Replies Latest reply: Aug 31, 2014 2:25 PM by EdAnuff
Ken Machacek Level 1 Level 1 (0 points)

Hello, all.

 

I have a new Mac Pro (Late 2013) with 6 cores, 32 GB RAM, and dual D700 AMD graphics cards.  I'm using an older 30 inch Apple Cinema Display (with the dual link DVI adapter).  I've successfully installed Windows 8.1 under Boot Camp.  Here's my problem...

 

I understand that for the new Mac Pro under Boot Camp enables AMD CrossfireX by default from multiple sources online.  However, it's disabled on mine, and every time I try to enable it (and hit "Apply" in the AMD Control Center), it disables again.

 

Is Crossfire only available for use with a Thunderbolt Display attached?  Could that be the problem?  Or is the AMD Control Panel lying to me?

 

Now, games in Windows are still running well... But I'd like to take full advantage of the dual graphics cards in the new Mac Pro with Crossfire.  Any help is greatly appreciated, thanks!

  • Ken Machacek Level 1 Level 1 (0 points)

    Fixed it!

     

    So, not only would Crossfire not enable under Windows 8.1 on my Mac Pro in Boot Camp... But Windows started crashing massively.  I was about to wipe Boot Camp entirely and try a clean install (even though the only three things I'd installed were Windows itself using Apple's exact instructions, Steam, and Skyrim), but decided in a last ditch effort to try disconnecting and reconnecting peripherals.

     

    Turns out the culprit was my Belkin Thunderbolt Express Dock.

     

    Disconnecting the Belkin Thunderbolt dock not only stopped Windows from crashing, but now I can enable Crossfire, as well!

     

    Now, this is especially strange since I have read elsewhere that people have no problems using the Belkin dock under Boot Camp with other Macs... This issue is probably isolated to using it in Boot Camp with the new Mac Pro.  But disconnecting the dock from my Mac Pro has solved not just one but all of my Boot Camp issues.  (Of course, using the Belkin dock under OSX on my Mac Pro is no problem.)

     

    Long story short, if you have a new Mac Pro and plan on using Windows 8.1 under Boot Camp, don't have the Belkin Thunderbolt Express Dock attached.

     

    I'm going to contact Belkin and tell them what I've discovered.

     

    Hope that helps y'all.

  • Ken Machacek Level 1 Level 1 (0 points)

    Oh, and Skyrim (even with a bunch of visual mods) runs incredibly well at Ultra settings, full resolution under Boot Camp, if anyone was curious.  Truly awesome.

  • EdAnuff Level 1 Level 1 (15 points)

    Commenting here in case anyone else finds this thread the same way I did while experiencing the same problem.  I also couldn't get the CrossFireX enable button in the FirePro control panel to stay active.  As soon as I hit Apply, it immediately disabled.  The solution was to shutdown, unplug every thunderbolt connection except for a single monitor and the external drive, and start up again into Windows.  I was then able to turn CrossFireX back on.  Interestingly, once I'd done this, after I shutdown again, reattached my second monitor and the other thunderbolt devices, and started up again, I found that CrossFire was still enabled.  It's possible that this is some sort of thunderbolt bus issue rather than a problem with a specific thunderbolt device as the OP speculated, since I don't have the Belkin Dock.