8 Replies Latest reply: Mar 31, 2014 4:18 AM by Maorriyan
Maorriyan Level 1 (0 points)

Hi All,

After updating my OS X to version 10.9.2, Safari could not display few webpages properly. And some of them are Apple Webpages.

Has anyone facing same issue?

Would anyone know how to fix this?


Safari Error-2.png

Safari Error-1.png


Safari Error-5.png







Message was edited by: Maorriyan

MacBook Pro (15-inch Early 2011), OS X Mountain Lion
  • QuickTimeKirk Level 9 (52,210 points)

    The pages didn't completely load all expected files.

    Try reloading or  refreshing the page by using the command-r keys.

    If that gives the same results shut down the computer and router and restart them.

  • Maorriyan Level 1 (0 points)


    I tried those and still having same issue

  • Linc Davis Level 10 (192,335 points)

    If the Develop menu isn't showing in the Safari menu bar, select

    Safari Preferences... Advanced Show Develop menu in menu bar

    Uncheck any checked items in the menu that start with the word "Disable." You can then go back to the Preferences window and disable the Develop menu itself, if you wish.

  • Maorriyan Level 1 (0 points)

    This is what I found from web inspector.

    It says: "failed to load resource: The certificate for this server is invalid. You might be connecting to a server that is pretending to be "fbstatic-a.akamaihd.net which could put your confidential information at risk"


    What does this means?


    How to fix it?

    Safari Error-6.png

  • Linc Davis Level 10 (192,335 points)

    That's an internal error from Facebook's network. There may be nothing you can do about it except to wait, or you may be able to work around it by changing your DNS settings.


    From the menu bar, select


    ▹ System Preferences... ▹ Network ▹ Advanced... ▹ DNS


    Under DNS Servers you should have one or more numerical addresses, such as “” or “”. What are those addresses?

  • Maorriyan Level 1 (0 points)

    No issue with Firefox.

    Facebook and Apple GeniusBar reservation working fine. All display as it shoud be.


    Is there any Safari settings I should change?

  • Linc Davis Level 10 (192,335 points)

    From the Safari menu bar, select


    Safari Preferences... Privacy Remove All Website Data


    and confirm. Test.

  • Maorriyan Level 1 (0 points)

    Brought this issue to Apple GeniusBar.

    Solved the issue by reinstalling the whole OS X