10 Replies Latest reply: Mar 18, 2014 7:53 PM by The Art Of Sound
Xreez Level 1 Level 1 (0 points)

How can I fix the fact that whenever I try to open Arpeggiator from the Smart controls, Logic pro X hangs forever?

 

Thanks


Logic Pro X, OS X Mountain Lion (10.8.5)
  • The Art Of Sound Level 6 Level 6 (9,140 points)

    Try doing things in this order....

     

    Create a new project

     

    Create an Instrument track...

     

    Add a Software Instrument... Choose an Apple one like a piano for example..

     

    Now select the Arp in the Midi FX button...

     

    Does it still hang then?

  • Xreez Level 1 Level 1 (0 points)

    Hello; Thanks for responding.

    I did that sequence that you advised me (in the same order with an apple instrument- Classic electric piano)

    but as soon as I choose Arpeggiator in the MIDi FX button, it shows that swirling ball cursor forever,,

    Is ther a way to re-install LPX 10.0.6??

     

    I saw one of your posts advising to delete logic prefs searching with finder and "go to folder" but it doesn't show the file you mention. I have Mountain Lion OS, and now I'm downloading mavericks.

     

    Thanks

  • The Art Of Sound Level 6 Level 6 (9,140 points)

    I saw one of your posts advising to delete logic prefs searching with finder and "go to folder" but it doesn't show the file you mention. I have Mountain Lion OS, and now I'm downloading mavericks.

     

    If you cant find those files then you are looking in the wrong place.... as they have to be there...

     

    Again, here is those instructions....

     

    http://support.apple.com/kb/HT5859

     

    and specifically....

     

    Delete the user preferences


    You can resolve many issues by restoring Logic Pro X back to its original settings. This will not impact your media files. To reset your Logic Pro X user preference settings to their original state, do the following:


    1. In the Finder, choose Go to Folder from the Go menu.
    2. Type ~/Library/Preferences in the "Go to the folder" field.
    3. Press the Go button.
    4. Remove the com.apple.logic10.plist file from the Preferences folder. Note that if you have programmed any custom key commands, this will reset them to the defaults. You may wish to export your custom key command as a preset before performing this step. See the Logic Pro X User Manual for details on how to do this. If you are having trouble with a control surface in Logic Pro X, then you may also wish to delete the com.apple.logic.pro.cs file from the preferences folder.
    5. If you have upgraded from an earlier version of Logic Pro, you should also remove~/Library/Preferences/Logic/com.apple.logic.pro.
    6. Restart the computer.
  • Xreez Level 1 Level 1 (0 points)

    Hello, Thanks again.

     

    Unfortunately nothing has worked. I found the files in the preference  folder, delete them, restart... still the same problem. I have re-installed LPX, restart still the same.

     

    Regards

  • The Art Of Sound Level 6 Level 6 (9,140 points)

    Have you used an iPad app with Logic? if so make sure your iPad/iPhone is turned off and then test again in case something there is conflicting with the Arp function.... Also unplug any midi controllers.. restart your Mac and again test the arp feature...

  • Xreez Level 1 Level 1 (0 points)

    I don't use iPAd app and I don't have iPAd/iPhone. The problem is still there. Arpeggiator is the only MIDI Fx that has a conflict. Can it be the OS?

  • The Art Of Sound Level 6 Level 6 (9,140 points)

    It could be... You said you were upgrading to Mavericks.. so maybe that will fix it but I haven't come across this issue in the past.... either with ML or Mav.. However since I used ML.. LPX has been updated so maybe it is a combo of the OS and LPX versions that is causing the problem.

  • Xreez Level 1 Level 1 (0 points)

    I'll post the result as soon as I complete the downloading of Mavericks. Thanks

  • Xreez Level 1 Level 1 (0 points)

    Finally, I installed the upgrade to MavericksOS X 10.9.2, and the problem was gone; I can now open Arpeggiator in LPX and it launches imediately.  Thanks for your responses.

  • The Art Of Sound Level 6 Level 6 (9,140 points)

    Excellent news...

     

    Thanks for the feedback and letting us know what fixed the issue for you....

     

    Cheers...

     

    Nigel