12 Replies Latest reply: Sep 10, 2015 8:22 AM by delgado2588
AliCC Level 1 Level 1 (0 points)

iCloud Keychain on iOS 7.1 keeps asking me to approve security code and when I write it, it asks me again. And keeps repeating.  I chose approve from other device (I have a MBA) but nothing appeared on it. The Keychain button in iOS setting says pending.


What should I do to fix this?

iPhone 5, iOS 7.1, KeyChain works fine on my Mac
  • griff w Level 4 Level 4 (3,465 points)

    Hi there AliCC,


    You may find the troubleshooting steps in the article below helpful.


    iCloud: Troubleshooting iCloud Keychain



    -Griff W. 

  • Branthamal Level 1 Level 1 (0 points)

    Thanks griff w but unfortunately found nothing of help there.


    "keeps asking me to approve security code and when I write it, it asks me again. And keeps repeating.  I chose approve from other device (I have a MBA) but nothing appeared on it. The Keychain button in iOS setting says pending."


    Exactly the same here.


    The AppleSupport article is useless it skims by saying, "follow instructions on screen"


    Essentially if you are stuck in this pending loop. You're stuck !

  • nam-mac Level 1 Level 1 (5 points)

    What you'll probably have to do is reset your keychain. you can do that by going to (on your Mac) System Preferences > iCloud > select Keychain (and enter your password) > Use Code... > Forgot Code? > Reset Keychain...

    Then you can go ahead and recreate your keychain from any device of your choosing (Mac, iPhone, iPad).

    The device you choose will have it's keychain data uploaded to iCloud and be the master keychain that the rest of your devices will then merge with.


    -hope that helps





  • Mas9311 Level 1 Level 1 (0 points)

    Thank you! Finally, after an hour or troubleshooting, the first answer that ACTUALLY worked.

  • broadwyfrog Level 1 Level 1 (0 points)

    Darn. I was having the same problem. Sadly, by May 1, 2015, this process no longer solves the issue.

  • Wudstock Level 1 Level 1 (0 points)

    I too am having the same issue and it started with iOS 8 on my iPhone 5s. Keychain will not turn "OFF" but will stay "Pending". Then about once a week I find a message on the phone saying I have to authorize Keychain. It doesn't matter if I type the code or authorize with another device it always fails.


    My iPad 2 running iOS 8 works great! Keychain is turned off and stays that way.


    I have exclusively used iPhone since the beginning in 2007, but I have to be honest, I think this was the last straw for me and Apple iPhone as I don't think I'll get another one. The bigger Apple gets the worse their 'Services' get. iCloud crashes left and right, Photostream doesn't work half the time. Every new iOS update adds a folder where photos are stored on the phone making it ultra confusing where the last picture I took is. Then iTunes stops Wifi syncing with the phone so I have to power it down and back up to get iTunes to see it again. It's just too much Apple! I need a phone that 'Just Works' as advertised, not one that I have to tweak/shut off/reset all the time to get to work.

  • neoteric5 Level 1 Level 1 (0 points)

    Actually, I tried selecting "Forgot Code?" on my iPhone (where I was experiencing the endless loop of Pending approval), reset my Keychain from my iPhone, and that finally cleared things up.  (Then I had to re-enable my Keychain on my Mac and other devices, which worked.)

  • Monijt Level 1 Level 1 (0 points)

    This worked for me. Thanks!

  • scottg45 Level 1 Level 1 (0 points)

    nam-mac, thanks for this posting this solution.  I've looked off and on over several months and this is the only solution that worked.

  • brockfromok Level 1 Level 1 (0 points)

    This is great.  Worked for me on the latest iOS 8 as of this date.  The sad thing is that I called apple about it and they could not help at all.  They "never heard of this issue".  I have found that calling tech support doesn't get anything fixed unless you get into the second and third tier of supporters.  Thanks to this post I've finally fixed my issue.  I have had the issue for a while now, just getting around to dealing with it. 

    I found that I had to reset the keychain from my mac and at the same time reset the keychain from my iPhone.  Get them both to square 1, then set up on my phone and then mac.  That is the only way it worked for me.  I literally tried 5 or ten times on both devices in different ways.


    Hope that helps.

  • ab1297 Level 1 Level 1 (0 points)

    Hey guys, I have another solution that worked for me without having to reset my keychain... Let me clarify, I wanted to turn KeyChain ON on my iPhone after having it replaced at the apple store. This worked for me, I have a Macbook Pro.


    On MBP:


    1. Go to System Preferences -> Icloud

    2. Scroll down to Keychain, uncheck the box. Confirm you don't want keychain on the Mac, but click where it says "keep on this mac" or something along the lines of that.

    3. After box is successfully unchecked, check it back again.

    4. After logging in, it will ask if it can approve your iPhone as well.


    Again this worked for my particular case, give it a try, it might work for you as well...



  • delgado2588 Level 1 Level 1 (0 points)

    I had this exact problem that was beyond frustrating because all the forums I searched and tried did not solve my issue. Turns out the problem was local and I finally figured out what to do so if anyone reading this is experiencing this same message, try this:


    1. Go to finder window

    2. At the very top where the menu is, click on 'Go'

    3. Hold the 'option' key and a 'Library' should suddenly appear in the dropdown list. Click it.

    4. Navigate to the folder called 'Keychain'

    5. Drag and drop it to desktop

    6. Restart

    7. After reboot, it may or may not ask you first thing to enter your appleID password. Enter it.

    8. Now go to Systems Preferences > iCloud

    9. You should now see that Keychain is no longer checked, and you should be able to then trash the folder on your desktop


    Be aware that doing this does mean you will lose your saved passwords and/or credit cards stored, but there aren't any other options (at least that I came across) to resolve this issue anyway. In my case, I was so frustrated with the approval messages popping up on my other devices and keychain being stuck in the pending state, that I gladly was willing to start over.