13 Replies Latest reply: Nov 1, 2014 2:50 PM by Ralph Johns (UK)
tamara201 Level 1 Level 1 (0 points)

I am having another version of the prominent iMessage and Facetime login issues (getting message: Could not sign in. Please check your network connection and try again).  Although I can't be sure , I think I've had this issue since Mountain Lion as I can't recall ever being able to login successfully but have never trouble shooted the problem until now, so my version of the problem may not necessarily be related to Mavericks.

 

In the past, when I was not able to get my MacBook Pro (mid-2009) connected, I just let it be since I didn't have the time to troubleshoot my routher settings etc.  Recently, due to a HD failure, I installed a new HD and reinstalled Mavericks.  During this process, I also upgraded my old desktop (iMac mid-2008) to Mavericks and discovered that it had no trouble connecting to iMessage/Facetime.  Therefore the problem is clearly with my MacBook Pro - not with my router/server (if I am deducing correctly).

 

While I am not computer illiterate, I am not as well-versed as many of the pros on these forums, so keep this in mind as I recount what I have done so far (in no particular order):

-Checked GameCenter, I can login to this without trouble

-Reset PRAM/NVRAM (I suspect this may be moot with Mavericks, but hey, it was worth a try)

-Deactivated Firewall, restarted, tried login.  This didn't work

-Deleted relevant plist files (FaceTime & iMessage), restarted.  No login possible.

-Logged into Guest account on my computer, still couldn't log in.

-Deleted, reset Keychain, still no success.  De-linked from iCloud also.

-Got more familiar with Console.  It seems that I keep getting 'apsd[67]: Unrecognized leaf certificate' in the process, and 'identityservicesd[221]: [Warning] IMSetKeychainData: -67808 -- Could not store data for service: com.apple.facetime' during the attempted logins.

 

 

I have probably tried a few other things that I have forgotten, but that's the bulk of the efforts.   I am guilty of having installed Sophos and a few other freeware utilities that I have now deleted - it is entirely possible that one of those apps messed things up.

 

Any help appreciated.

 

Thanks Community!


MacBook Pro (17-inch Mid 2010), OS X Mavericks (10.9.2)
  • Ralph Johns (UK) Level 9 Level 9 (69,315 points)

    Hi,

     

    If you had Mountain Lion at version 10.8 and 8.1 it may have stopped working at OS X 10.8.2

     

    This particular Update (and since) has required the Serial Number of the Mac to be readable from the logic/mother board.

     

    In the Apple Menu > About this Mac click twice on the line that read the current OS version.

    The first click shows you the Build Number (Another was to work out which OS version)

    It will then change to the Serial Number.

     

    It is supposed to be "flashed" to the board if the board was replaced in a repair or a refurbishment.

     

    If it is missing you need to take the Mac to an Apple Store or an Apple Authorised  Service Provider (AASP  (UK Link)).

    I have yet to see anyone saying they have been charged for this.

     

    IF the Serial Number was incorrectly entered it is a New board as it can only be done once.

     

     

     

    3Sigcopy2.png

    8:45 pm      Thursday; March 20, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • Linc Davis Level 10 Level 10 (153,540 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, by a peripheral device, by a font conflict, or by corruption of the file system or of certain system caches.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards, if applicable. Start up in safe mode and log in to the account with the problem. You must hold down the shift key twice: once when you boot, and again when you log in.

       

    Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a Fusion Drive or a software RAID, you can’t do this. Ask for further instructions.

     

    Safe mode is much slower to boot and run than normal, with limited graphics performance, and some things won’t work at all, including sound output and Wi-Fi on certain models. The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (not in safe mode) and verify that you still have the problem. Post the results of Steps 1 and 2.

  • Nikonic Level 1 Level 1 (15 points)

    I spent several days trouble shooting my inablility to login to my account with Facetime or Messages (other cloud services worked) after upgrading to Mavericks.  I went as far as doing a clean install on my hard drive after spending two hours with a baffled mac tech in a retail store and many hours searching the message boards.

     

    I have never had a logic board (or hard drive) replaced on my Macbook Air, but somehow after the Mavericks update the logic board stopped reading the serial number on my system.  It took a call to Apple and a ticket opened to engineering to figure this out (after I uploaded log files).

     

    They were puzzled I experienced this without a logic board replacement, but it was indeed the root cause of the facetime and messages apps failing to log in, and said they'd run in to it recently more than once.

     

    Wish I knew how to post this unbiquitously across all the boards for folks to troubleshoot by simply looking at their system info in the Apple menu; Apple scheduled an appointment for me at an Apple genius bar and it was fixed in fifteen minutes.

  • Ralph Johns (UK) Level 9 Level 9 (69,315 points)

    Hi,

     

    Thanks for that information.

     

    Recently I have been asking people to look thinking they were updating late to Mavericks and in some case bypassing the OS X 10.8.2 threshold for discovering this issue.

     

    It does seem strange that Mavericks is causing this.

    I would guess it is something to do with Sandboxing some of the Apps and Information the Mac uses.

     

    There are two ways to be somewhat all inclusive with the info.

    1) Search for all the threads with identifying markers (Mac OS X 10.8.2 and Serial Number might do it)

     

    2) Get to a point where you are allowed to create User Tips and add such a tip there.

     

     

    3Sigcopy2.png

    8:57 pm      Sunday; March 23, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • Cronic03 Level 1 Level 1 (0 points)

    Hi, I have done much reading in many places for this issue and as of now none of the advice has worked for me. I am a tech savvy guy and have had every Mac Laptop and OS created to date. I just bought a used MacBook 5,1 from a friend who was the first owner. I did a fresh install of 10.9.2 Mavericks and wen't about setting up my iCloud and iMessages only to discover that iMessage won't actually login and neither would FaceTime. In an attempt to figure out what the issue was I verified the disk permissions only to find an absurd number of permission differences. I have repaired all but one. Every time I verify and repair it says its successful but never goes away. That is not my main concern, iMessage and FaceTime is. From what my friend says he had the keyboard replaced when it was still under warranty with Apple. No LogicBoard or MotherBoard replacements. The Serial Numbers match and the TimeZone is set to automatic. I have tried multiple iCloud logins but got the same result. I have deleted all .plist files suggested and also did a KeyChain Reset, no luck. I am at my wits end with this and beg for help. Attached are my Logs from the DiskUtility and Console. Can someone PLEASE guide me in the right direction.

     

     

    Here are links to my DropBox with the logs and a screen shot of the error I get with Messages.

     

    https://www.dropbox.com/s/qeukeh5v0v49hr1/Mavericks_Console_Log_Errors.rtf

     

    https://www.dropbox.com/s/c9x5152221j6vqv/Mavericks_Permissions_Error.rtf

     

    https://www.dropbox.com/s/7s2w4u1vuxot4ia/Screen%20Shot%202014-05-10%20at%207.59 .11%20PM.png

     

     

    Please let me know if any more info is needed and I will post promptly.

    Thanks to everyone in advance!

     

    T.J.

  • Ralph Johns (UK) Level 9 Level 9 (69,315 points)

    Hi,

     

    Possibly the Mavericks Console Errors shows a DNS issue.

    It looks like mDNS (Bonjour)  is having difficulty starting up.

    The cause could be this http://support.apple.com/kb/HT3789

     

    The second link about permissions is virtually unreadable in the form posted.

    However I have things that remain in the List despite a previous "Permissions Corrected" message the last time.

    I doubt the issue is showing up here.

     

    The Link title with the dots in the Time listing of that screen shot may not be the way the DropBox server stores them  The Mac OS X can deal with the Screen Shot naming format but other systems cannot.

    i.e. the link returns a 404 Error from DropBox

     

    Is the Apple ID linked to iCloud already ?

    I linked one of my Apple IDs at the time iCloud Started (it gave me an additional @Me.com ID email and later an @icloud.com one).

     

    I have several @mac.com IDs that I have not linked to iCloud which I got as "iChat Names" from the @mac.com registration site after MobileMe was the Apple Service.  (Apple kept the registration page open and the names only worked as Apple IDs and as valid AIM Screen Names - they were never email accounts)

     

    I have tired to "iCloud" one but found I have removed the linking email account meaning I can't get it verified for iMessages.  (to create the @mac.com ID I had to link it to an email that was valid - however you could remove that email later an use it again to create another @mac.com ID)

     

     

    3Sigcopy2.png

    8:53 pm      Sunday; May 11, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • AppleQuacks420 Level 1 Level 1 (0 points)

    I FOUND THE FIX!!!!!

     

    Back up all data.

    Triple-click anywhere in the line below on this page to select it:

    ~/Library/IdentityServices

    Right-click or control-click the line and select

              Services Reveal in Finder (or just Reveal)

    from the contextual menu.* A folder should open with an item selected. Move the selected item to the Trash. Log out or restart the computer, empty the Trash, and test.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard by pressing the key combination  command-C. In the Finder, select

              Go Go to Folder...

    from the menu bar and paste into the box that opens by pressing command-V. You won't see what you pasted because a line break is included. Press return.

     

    Basically drag the items in the identityservices folder to trash log out, log back in, empty trash, start messages or facetime!!

  • Abraham Girt Level 1 Level 1 (5 points)

    Hello,


    I found it out!

    (This fixes every issue on your computer) iPhone, iPad, I don't know.

     

    1. Install OS X Mavericks 10.9.5

    2. App Store > Look up FaceTime > Buy the App… If it gives you a error that you already have the App just click "OK".

    2. System Preferences > Time and Date > Click checkbox at top "Set Time and Date automatically"

    2. Log out, restart, or shut down > When logged back in Now it will ask you for your password > Enter your password > Open FaceTime and sign in!

     

    If this does't work try to experimenting by logging out logging in restarting or shutting down your device.

  • scastaldi Level 1 Level 1 (0 points)

    I was able to fix it by login into iMessage, when you get the Error number, call support. They will reset the account and get everything working, the best thing is that I didn't have to pay      (I don't have apple care). By giving the number you get when the iMessage error they take care of the problem, I guess they know they messed up

     

    Hope this help,

    Sebastian

  • REDNIRT Level 1 Level 1 (0 points)

    Ralph

    I too had a problem getting iMessages to login and after much fiddling I de-installed Little Snitch which was blocking it somehow but I am not certain exactly what. I had to use the Little Snitch de-installer to do this.

  • REDNIRT Level 1 Level 1 (0 points)

    I too had a problem getting iMessages to login and after much fiddling I de-installed Little Snitch which was blocking it somehow but I am not certain exactly what. I had to use the Little Snitch de-installer to do this.

  • Ralph Johns (UK) Level 9 Level 9 (69,315 points)

    Hi,

     

    Most likely the middle of these three:-

    Screen Shot 2014-11-01 at 20.40.13.png

    The IMRemote items is involved in the iMessages Login.

     

    EDIT

    Higher up is also this unlikely looking item.

    Screen Shot 2014-11-01 at 20.46.27.png

    The iMessages Servers "Push" the iMessages to the devices.

     

     

    3Sigcopy2.png

    8:41 pm      Saturday; November 1, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • Ralph Johns (UK) Level 9 Level 9 (69,315 points)

    Sorry Late catch on this related but different issue.

     

    Apple ID.png

    If you get this Error messages it can ONLY be fixed by Support Staff.

    That's not to say that first line operatives know about it - they tend to focus on Software and Hardware issues.

    This is an Account issue.

    It only effects the Mac and the iMessages account  (it will still work on iOS devices and on other computers)

    As an Account Issue it does not Cost when phoning up (other than the call itself).

    If you have problems, ask to speak to a Level 2 person.

     

     

    3Sigcopy2.png

    9:50 pm      Saturday; November 1, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad