11 Replies Latest reply: Mar 24, 2014 9:36 AM by Linc Davis
etiennegrosjean Level 1 Level 1 (0 points)

Since a couple of day I canot access my td account in Safari. I gat the initial page with my accout and password, I press login and the only thing I get is a blank page. OK on iPhone, iPad and Goggle Chrome. Maverick 10.9.2 Safari 7.0.2.


iMac (27-inch Late 2009), OS X Mavericks (10.9.2), Safari 7.0.2
  • Carolyn Samit Level 10 Level 10 (100,080 points)

    Might be a cookie and/or cache issue.

     

     

    On Safari ...  from the Safari menu bar click Safari > Preferences then select the Privacy tab.

     

    Click Details.

     

    Type TD or TD Ameritrade in the search field top right corner of that window.

     

    When you see the results, cick Remove or Remove All.

     

     

    Now empty the Safari cache.

     

    Back to Safari > Preferences select the Advanced tab.

     

    Select:  Show Develop menu in menu bar

     

    Now click Develop from the menu bar. From the drop down menu click Empty Caches.

     

     

    Quit and relaunch Safari then try the TD site.

  • etiennegrosjean Level 1 Level 1 (0 points)

    I tried it. It does not work. I used tdcanadatrust.

  • Linc Davis Level 10 Level 10 (172,860 points)

    From the Safari menu bar, select

            

    Safari Preferences... Extensions

         

    Turn all extensions OFF and test. If the problem is resolved, turn extensions back ON and then disable them one or a few at a time until you find the culprit.

     

    If you wish, you may be able to salvage the errant extension by uninstalling and reinstalling it. Its settings will revert to their defaults. If the extension still causes a problem, remove it permanently or refer to its developer for support.

  • etiennegrosjean Level 1 Level 1 (0 points)

    It is exactly the same thing with all extensions turned off.

  • Linc Davis Level 10 Level 10 (172,860 points)

    Boot in Recovery mode. In the OS X Utilities screen, select Get Help Online. A clean copy of Safari will launch. No plugins, such as Flash, will be available. While in Recovery, you'll have no access to your saved bookmarks or passwords, so make a note of those before you begin, if they're needed for the test.

     

    Test. After testing, reboot as usual and post the results.

  • etiennegrosjean Level 1 Level 1 (0 points)

    This reinstall Maverick. I id it. It kept all preferences. But TD is still the same.

  • Linc Davis Level 10 Level 10 (172,860 points)

    I didn't suggest that you reinstall anything. Please answer the question that was asked.

  • etiennegrosjean Level 1 Level 1 (0 points)

    Oh! I misundersttood. I went to Recovery and I fixed the disc and reistalled Maverick...

  • Linc Davis Level 10 Level 10 (172,860 points)

    The question was whether you could access the account in Safari while in Recovery mode.

  • etiennegrosjean Level 1 Level 1 (0 points)

    Sudendly, it works... The last thing I did was to load Java for Genieo after my reload of Maverick. I suspect the web page of TD canada trust need Java but I do not have proof.

     

    I tried to load Safari in recovery but it asked a password and I entered all the passwords I know without succes... Ennterig all those password is such a pain...

  • Linc Davis Level 10 Level 10 (172,860 points)

    You installed the "Genieo" search-hijacking rootkit. The product is a fraud, and the developer knowingly distributes an uninstaller that doesn't work. I suggest the tedious procedure below to disable Genieo.

    Back up all data. You must know how to restore from a backup even if the system becomes unbootable. If you don't know how to do that, or if you don't have any backups, stop here and ask for guidance.

    Step 1

    Triple-click anywhere in the line below on this page to select it:

    /etc/launchd.conf

    Right-click or control-click the line and select

    Services Reveal in Finder (or just Reveal)

    from the contextual menu.

    If you don't see the contextual menu item, copy the selected text to the Clipboard by pressing the key combination command-C. In the Finder, select

    Go Go to Folder...

    from the menu bar and paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

    A folder may open with a file selected, or the file may not exist, in which case you'll get a message that it can't be found. If it does exist, it's a configuration file created or replaced by the Genieo installer. Any software installer that does this should be considered ipso facto malware. Move the file to the Trash. You'll be prompted for your administrator password. Then restart, empty the Trash, and continue as below.

    IMPORTANT: If the launchd.conf file exists, you must move it to the Trash and restart before continuing. Otherwise the system may become unbootable. In that case, restore from your backup and start over. That's how badly Genieo has sabotaged your system. If you're not completely sure you can complete this step, stop here and ask for guidance.

    Some variants of Genieo don't include the launchd.conf file. The absence of that file doesn't mean that Genieo is not installed.

    Step 2

    Quit the Genieo application, if it's running. Force quit if necessary.

    Move each of these items to the Trash in the same way as above:

    /Applications/Genieo.app
    /Applications/Uninstall Genieo.app
    /Library/Frameworks/GenieoExtra.framework
    /Library/LaunchAgents/com.genieo.engine.plist
    /Library/LaunchAgents/com.genieoinnovation.macextension.plist
    /Library/LaunchDaemons/com.genieoinnovation.macextension.client.plist
    /Library/PrivilegedHelperTools/com.genieoinnovation.macextension.client
    /usr/lib/libgenkit.dylib
    /usr/lib/libgenkitsa.dylib
    /usr/lib/libimckit.dylib
    /usr/lib/libimckitsa.dylib

    There's no need to restart after each one. Again, some of these items may be absent, in which case you'll get a message that the file can't be found. Skip that item and go on to the next one.

    Restart and empty the Trash. Don't try to empty the Trash until you have restarted.

    Your web browser(s) should now function normally, and you should be able to reset the home page and search engine. If not, stop here and post your results.

    Step 3

    From the Safari menu bar, select

    Safari Preferences... Extensions

    Uninstall any extensions you don't know you need, including ones called "Genieo" or "Omnibar," and any that have the word "Spigot" or "InstallMac" in the description. If in doubt, uninstall all extensions. Do the equivalent for the Firefox and Chrome browsers, if you use either of those.

    This procedure may leave a few files behind, but it will deactivate any version of Genieo that I know of. Make sure you don't repeat the mistake that led you to install it. Chances are you got it from one of the Internet's open sewers such as "Softonic" or "CNET Download." Never visit either of those sites again. You might also have downloaded it from an ad in a page on some other site.

    Finally, be forewarned that when Genieo is mentioned on this site, the developer sometimes shows up under the name "Genieo support." If that happens, don't believe anything he says, but feel free to tell him what you think of his scam.