2 Replies Latest reply: Mar 28, 2014 10:40 AM by Bob Timmons
BadaxeMac Level 1 Level 1

I am running os10.5.8 on an imac8,1 airport utility 4.2.3. have an old base station V6.3 and purchased new airport extreme but it wont run.  Question; can I upgrade via free downloads or am I stuck installing snow leopard et al to run my new airport extreme?


iMac, Mac OS X (10.5.8)
Reply by Bob Timmons on Mar 28, 2014 6:20 AM Helpful

You might want to review the System Requirements for the the new AirPort Extreme from the product technical specifications linked below:

 

Tech Specs

 

Setup and Administration

 

  • iPhone, iPad, or iPod touch with iOS 6 or later and AirPort Utility 1.3

 

         or

 

  • Mac with OS X Lion v10.7.5 or later and AirPort Utility

All replies