3 Replies Latest reply: Mar 31, 2014 4:41 AM by a brody
tagtom2 Level 1 Level 1 (0 points)

my macbook operates on OS X 10.6.8  Quickbooks needs OS X 10.7.3  is it ok to upgrade to that operating software?


MacBook Pro (13-inch Mid 2010), Mac OS X (10.6.8)