5 Replies Latest reply: Apr 16, 2014 9:02 AM by sjneufeld
sjneufeld Level 1 (0 points)

Apologies if my terminology is less-than-correct...


For months my connection to my work's remote windows server worked just fine: I connect to a VPN, then use "connect to server" and enter the I.P. address of the shared drive.  At that point I am asked for a user name and password and then the shared drive appears on my desktop.


Now the connection is no longer working.  I can connect to the VPN, and when I "connect to server" I get to the username and password stage.  Once I've entered my password, I get the following error:


There was an error connecting to the server "XX.X.X.X". Check the server name or IP address, and then try again.  If you are unable to resolve the problem contact your system administrator.


Interestingly, I can still connect to the shared drive using the Remote Desktop Connection.  It is only when I try to mount the drive through "Connect to Server" that I seem to run into this problem.


I don't know how to tell if this is a problem at my end or at the servers end.  Any thoughts?  Thanks!

iMac, Mac OS X (10.6.8)
  • sjneufeld Level 1 (0 points)

    further to my previous post - I have been able to use smbclient in Terminal to do some things.


    I don't really know what they mean, but clearly my computer is able to connect and interact with the server.  It just isn't able to mount the drive.  Or maybe there is some other command to use in Terminal that will allow me to mount the drive - I am not very familiar with smbclient.


    $ smbclient -L NAME -I i.p.address -U username


    Domain=[HO] OS=[Windows Server 2003 R2 3790 Service Pack 2] Server=[Windows Server 2003 R2 5.2]



              Sharename       Type      Comment

              ---------       ----      -------

              print$          Disk      Printer Drivers

              C$              Disk      Default share

              Sh              Disk     

              In              Disk     

              CMS_SETUP       Disk     

              OCRM            Disk     

              IPC$            IPC       Remote IPC

              AD$             Disk      Remote Admin

              E$              Disk      Default share

              Business confidential Disk     

              Development Server Disk     

              Downloads       Disk     

    Domain=[HO] OS=[Windows Server 2003 R2 3790 Service Pack 2] Server=[Windows Server 2003 R2 5.2]



              Server               Comment

              ---------            -------






              YCK                  Yck



              Workgroup            Master

              ---------            -------

              HO                   GUEST

              WORKGROUP            IL-PC

  • sjneufeld Level 1 (0 points)

    one last addition.  This worked so that I could browse the server through Terminal.  So why isn't the cmd-K option working in Finder???


    $ smbclient //i.p.address/Share -U username


    Domain=[DOMAIN] OS=[Windows Server 2003 R2 3790 Service Pack 2] Server=[Windows Server 2003 R2 5.2]

    smb: \>

  • Antonio Rocco Level 6 (10,470 points)

    How are you entering the address when using the command+K option from the Finder's Go Menu? For example are you using this format: //Server's IP Address/Share Name; or are you using: smb://Server's IP Address/Share Name; or are you using: cifs://Server's IP Address/Share Name. What happens if you simply enter the Server's IP address instead?

  • sjneufeld Level 1 (0 points)

    Thanks for your response, Antonio.


    I've tried it in a couple of ways:

    smb://Server's IP Address/Share Name

    smb://Server's IP Address


    I hadn't heard of cifs:// but I just tried it and am getting the same error.

    I get nothing when I try with just

    //Server's IP Address/Share Name  (because it's attempting to use afp to connect to a Windows server).


    Are there preference files or something that could be corrupted? If so, where are they stored and can I just delete them and start fresh?

  • sjneufeld Level 1 (0 points)

    I don't know what changed, but everything suddely started working again.  The only thing I can think of is that I tried again to add the Share name before my username (i.e. SHARE\username) and now the password was accepted and I am mounting the drive as normal.


    I could swear I tried that before, but... who knows?