1 Reply Latest reply: Apr 4, 2014 12:36 PM by sheila_m.
subhashrees Level 1 Level 1 (0 points)

I am not able to install ibooks on my ipod touch. it says like latest itunes is required,but I checked and it is latest itunes only


iPod touch, iOS 6.1.6
  • sheila_m. Community Specialists Community Specialists (3,275 points)

    Hello subhashrees,

     

    Thank you for the question.  The latest versions of the applications will only work on iOS 7, but you can download a compatible version for your iPod touch using these steps:

     

    iOS 7 and OS X Mavericks include new features that many of your favorite apps take advantage of when you update them. Some of these features are specific to the latest versions of iOS and OS X. As a result, the latest versions of some apps may not work with your device or computer if you are still using an earlier version of iOS or OS X. Thanks to the App Store, you may still be able to re-download a compatible, earlier version of an app when you are using an older operating system.

    Here's how you install an earlier version of an app:

    1. Open the App Store (with iOS 4.3.3 or later) or Mac App Store (with OS X Mountain Lion only).
    2. Go to the Purchased screen (iOS) or Purchases tab (OS X).
    3. Select the app you want to download.

    If a compatible version of the app is available for your version of iOS or OS X, simply confirm that you want to download it. For example, after purchasing iPhoto for your iOS 7 device, you can install an earlier compatible version of iPhoto from your iOS 6 device.

    App Store: Install the latest compatible version of an app

    http://support.apple.com/kb/HT5919

     

    If you do not have a device with iOS 7 to purchase iBooks with, you can purchase it using iTunes on a computer so that it will be listed in the Purchases section of the App Store on your iPod touch.

     

    Thank you for using Apple Support Communities.

     

    Best,

    Sheila M.