13 Replies Latest reply: May 3, 2014 10:19 PM by Lewis Harvey
Fustbariclation Level 1 Level 1 (0 points)

I've upgraded to safari 7.0.3 and lots of sites have stopped working - they still work on firefox.

 

Is this a general problem, or is there something I need to configure for the new version to work?

 

Sites that don't work include mail.google.com & http://www.macrumors.com

 

How do I go back to the previous version?


MacBook Pro with Retina display, OS X Mavericks (10.9.1), 2,3 GHz Intel Core i7 8 GB 1600 MHz
  • dominic23 Level 7 Level 7 (31,240 points)

    Restart the Computer.

     

     

    Delete Caches.db

     

    Close all windows and quit all applications.

    Hold "option" key down and click "Go" menu in the Finder menu bar.

    Select "Library" from the dropdown.

     

    Library > Caches > com.apple.Safari > Caches.db

    Right click the Caches.db file and select "Move To Trash.

    Close windows and relaunch Safari.

  • Fustbariclation Level 1 Level 1 (0 points)

    I thought it had solved it - it is much quicker with gmail - but it still fails to load completely. Macrumours doesn't load either.

     

    So there's something wrong with the new Safari - Firefox is fast.

  • dominic23 Level 7 Level 7 (31,240 points)

    Nothing wrong with Safari 7.0.3

     

    I tried the Macrumors site and it opened fine.

     

    Reset Safari.

     

    Click Safari in the menu bar.

    From the drop down select "Reset Safari".

    Click "Reset".

     

    Delete Cookies

     

    Safari > Preferences > Privacy > Cookies and other website data:

    Click “Remove All Website Data”.

  • Fustbariclation Level 1 Level 1 (0 points)

    I've done all that - reset everything in sight. It still has trouble with the mac rumours site, but firefox, running at exactly the same time, doesn't.

     

    I'm not sure what is wrong with Safari 7.0.3, but something certainly is.

     

    Apart from the reset, I've also deleted the cache files, as was recommended, and re-booted.

     

    It looks as if the sensible option is to run firefox.

  • Fustbariclation Level 1 Level 1 (0 points)

    As I said - I've taken all the steps suggested. It works now with gmail, but still has problems with mac rumours.

  • dominic23 Level 7 Level 7 (31,240 points)

    Try these troubleshooting steps.

     

    1. Power off the router. Unplug it from the wall. Wait a while.

        Plug it back to the wall. Power the router on. Wait until all the lights are lit properly.

        It will take a while.

        Restart the computer.

     

        Start up in Safe Mode.

        http://support.apple.com/kb/PH11212?viewlocale=en_US

     

     

    2. Safari > Preferences > Privacy > Cookies and all other website data:

     

         Press “Remove All Website Data” button.

     

      

    3. Turn off Extensions if any, and launch Safari.

        Safari > Preferences > Extensions

  • Fustbariclation Level 1 Level 1 (0 points)

    I think I've tracked down the problem - it is Ad Blocker. Something is not working in the interaction between macrumours and adblocker that's started with safari 7.0.3.

     

    I was able to estabish this when I noticed that an advertisement had turned up on the firefox version - I installed ad blocker and the firefox site stopped working.

     

    I've reported the error to ad blocker.

  • Prashant Joshi Level 1 Level 1 (20 points)

    I am having a similar problem since updating. Many pages seem to load very slowly, one painful graphic at a time. I do not have any extensions running so ad blocker cannot be the problem in my case. I have posted on Macintouch but others are not having the problem. It is frustrating because both of my computers are having the same issue. I still have not solved it yet, but I will post if I do.

  • Serge Claymore Level 1 Level 1 (0 points)

    I had the same problem and disabling Ad Block solved it! Thanks Fustbariclation

  • tuco romero Level 1 Level 1 (5 points)

    Diabling Ad Block fixed it the problem for me also.

  • Lewis Harvey Level 1 Level 1 (0 points)

    I had all these problems: long delays loading some pages, blank pages that only loaded after clicking refresh several times. None of the solutions worked for me. But today I found this web page: http://www.thebitguru.com/blog/view/394-Random%20Slowdown%20of%20Browsers%20in%2 0OS%20X%20Mountain%20Lion

    My problem was due to the Cisco VPN Client that my employer recommends over the Apple built-in VPN client. I had duitifully installed it several months ago, did not prefer it over the built-in client and forgot about it (and of course did not bother to uninstall it). I have now uninstalled it using the included Cisco uninstaller, and now Safari 7.0.3 works like a charm. I noted that the Cisco files were still in the /opt folder after running uninstall, so to be on the safe side I trashed the whole Cisco folder that was in /opt.

    I hope this solution works for you all.

    Lew Harvey

  • sharmenUK Level 1 Level 1 (0 points)

    I had the exact same problem.

     

    Safari would just appear blank the minute I open it.

     

    All I did was to head over Safari --> Preferences --> Extensions --> Uncheck "AdBlock Plus" --> Uninstall Extension

     

    And after that Reset Safari from Safari --> Reset Safari --> Reset

     

    And you're good to go.

  • Lewis Harvey Level 1 Level 1 (0 points)

    I should have made it clear that I did not have AdBlock installed yet I still had the blank page problem with Safari 7.0.3. The Console indicated that there were "unable to verify license key" errors:

     

    3.05.2014 10:10:51.108 acwebsecagent[140]: OnConnectionFailure : Fail Open - Reason = Unable to verify the license key

     

    A Google search immediately led me to the page I cited above about the Cisco VPN AnyConnect client being the cuprit. Getting rid of that app solved my problem.