Previous 1 2 Next 18 Replies Latest reply: Jan 16, 2015 5:04 PM by Tavaren
Jay Clay Level 1 Level 1 (0 points)

The shared iTunes music and movie library stops loading on my ios devices.

iTunes 11.1.5 is set up for both home sharing and library sharing over my secured home wifi network. Home sharing between the mini that is running iTunes and my old Macbook works without any issues.

My ios devices can see and will eventually connect to the shared library but connecting is pretty slow unless the ios devices are in the same room with the mini.

After a few hours my ios connection to the shared music and movie library drops and stops loading halfway when I try to reconnect.

The ipad is running ios 7.1 and my iPhone is running ios 6.1.3.


iPad Air Wi-Fi, Cellular, iOS 7.1
  • braden85 Community Specialists Community Specialists (3,110 points)

    Hi Jay Clay!

     

    Here is an article that can take you through some troubleshooting for this issue with Home Sharing:

     

    Troubleshooting Home Sharing

    http://support.apple.com/kb/ts2972

     

    Take care, and thanks for visiting the Apple Support Communities.

     

    Cheers,

    Braden

  • Jay Clay Level 1 Level 1 (0 points)

    Hi Branden,

     

    Thanks for the prompt responce.

    I am not having a problem with Home Sharing (as stated in my original posting), only with Library Sharing with ios devices.

    All devices, laptops, minis and iTunes are current with the latest versions of their respective software versions and Yes, I can power cycle my router/modem and/or restart iTunes and the iPad but that doesn't really solve my issue with reconnecting to the Shared LIbrary.

    Thanks for the info regardless.

     

    Cheers,

     

    Jay

  • ILEFFLER Level 1 Level 1 (0 points)

    A Shared Library on any Apple Product is done by Home Sharing hence braden85's response.

     

    If you are sharing the library by other means then it is not an Apple issue, it would be an issue with the other developer.

  • Jay Clay Level 1 Level 1 (0 points)

    Wow, that was completely unhelpfull.

    Did you read through my original post that described the issue that I'm experiencing?

  • braden85 Community Specialists Community Specialists (3,110 points)

    Hi Jay Clay,

     

    Thank you for using the Apple Support Community. Due to the nature of your issue or question you may find more information by using another one of Apple's support resources - https://getsupport.apple.com/GetproductgroupList.action.

     

     

    Cheers,

    Braden

  • hagerty Level 1 Level 1 (0 points)

    I have the exact same issue.

  • Brian Steck Level 1 Level 1 (0 points)

    Hi Jay Clay and Hagerty,

     

    I'm in the same boat.  I'm running iTunes 11.2.2 on a Macbook Pro (running 10.9.3) and iOS 7.1.1 on an iPhone 4s; so running the latest version of software is not the issue.

     

    The username logs in correctly on all devices and I can actually see the iTunes library available to share on my device.  From "Music" on the phone, I go to "More > Shared" and then select the library that is shared from my Macbook.  So I know that the login information is correct.

     

    The circular status wheel begins to load and gets halfway around before it stalls and does not resume.  This process happens repeatedly, so it's reproduceable and consistent -- not a one-time issue.

     

    I've tried restarting both systems, but the same problem ensues.  I've also tried signing out and signing back into Home Sharing on all devices, which did not resolve the issue.  I've read and followed all the recommendations in "Troubleshooting Home Sharing", but these really only offer solutions if you're not able to see the shared library; which is not the issue that I believe Jay Clay, Hagerty and I are having.

     

    Some thoughts:

    • Could it be that the iTunes library is too large?
    • Could it be that Home Sharing times out if the library is not loaded in a set amount of time?

     

    I've attached a screenshot of what I'm seeing on my iPhone, for your reference.

    photo.PNG

     

    Also, here is the confirmation page I'm seeing in iTunes, so Home Sharing appears to be working.

    HomeSharingScreenshot.jpg

     

    Thanks in advance for your help!

  • pjl123 Level 5 Level 5 (6,155 points)

    happens to me from time to time as well.  Almost seems random.  2 things I have noticed - sometimes the mac has gone to sleep.  If I go jiggler the mouse to wake it up, it then does ok.  I wonder if it gets interrupted during that loading (and it can take some time), by same a time capsule update, or an incoming message, if it loses its way.

     

    I have noticed it is happening a lot less under 7..1.1 than it used to.

  • londonjer Level 1 Level 1 (0 points)

    I'm having the same problem as Brian, Jay Clay and Hagerty. 

     

    I used to run an ATV3, and had a similar problem, but it would sometimes just right itself.  Now I use a brand new Mac Mini as my media station connected to my TV, but sometimes I want to watch a movie in bed on my ipad- and this seems to happen.  Everytime.  My screen shot would be identiacal to Michael's.  Halfway through exactly, and then it hangs.  Latest software on all devices etc... Hopefully someone can help?  Have tried turning off the "Share library on my local network" option as well, as there were people with similar ATV problems that were solved by doing this.  No joy on that front.

     

    -jer.

  • londonjer Level 1 Level 1 (0 points)

    These guys all seem to have teh same problem...

     

    https://discussions.apple.com/thread/5334240?start=45&tstart=0

  • londonjer Level 1 Level 1 (0 points)

    OK- I've been doing a bit of playing around with this, and it seems that the Home Sharing issue is only affecting iOS devices, because it's fine with my Apple TV3, and also my old G4 MacBook.  Don't know if this helps, but seems like it's less of an iTunes issue, and more of a problem that might be resolved in a iOS update at some point soon. Fingers crossed.  I miss streaming movies to my iPad. (Just re-read original post and saw that this fact was already established-- sorry!!)

     

    Message was edited by: londonjer

  • londonjer Level 1 Level 1 (0 points)

    Just updated to ios8 thinking it might fix the problem.  It didn't, so started researching some more.  A guy on another discussion suggested changing some network settings to avoid clashes etc.  I've gone into my router settings and made some tweaks which show some improvement at least.  I have moved my wireless frequency from 2.4GHz to 5GHz and wireless mode from "up to 144mbs" to "up to 300mbps".  Immediately the thumbnails load in the background when I select my library in home sharing on the iPad now, but it's still waiting to load everything.  Seems a small step forward, but maybe this is the right track?  What else could move things along....anyone?

  • londonjer Level 1 Level 1 (0 points)

    Jay Clay-- don't know whether my reply was just to myself on this thread or not, but I just got it all to work.  See latest post from today:

     

    Just updated to ios8 thinking it might fix the problem.  It didn't, so started researching some more.  A guy on another discussion suggested changing some network settings to avoid clashes etc.  I've gone into my router settings and made some tweaks which show some improvement at least.  I have moved my wireless frequency from 2.4GHz to 5GHz and wireless mode from "up to 144mbs" to "up to 300mbps".  Immediately the thumbnails load in the background when I select my library in home sharing on the iPad now, but it's still waiting to load everything.  Seems a small step forward, but maybe this is the right track?  What else could move things along....anyone?


    UPDATE-- I had to leave the library to load for quite some time (10 minutes maybe)- but because the thumbnails appeared in the background I thought there might be hope, and there was.  Everything has loaded now and it stream fine.  I would expect a bug library to take time to load, but if the thumbnails appear after maker the changes to the router setting you might be in luck.  Hope this helps!

  • LifeboatParty Level 1 Level 1 (5 points)

    In my experience this problem absolutely is an issue with iOS. Some people with older software/hardware combinations (such as original iPad not upgraded) can use home sharing with no problem. I can use Apple Remote and third-party apps and access my admittedly large library with no slowdown, but I have given up hope that Apple will ever fix the problem with the Home Sharing over the Music app on iOS. I have done all the updates, spent countless hours on the phone with Apple Support, searched the Internet for a fix, all to no avail. I now use Mobi to play folders of my favorites from my Mac Mini and use Remote if I simply want to play to an AirPlay speaker. I wish you all the best, but I would not lose sleep over this issue thinking it's something with your setup or your library--the fault is completely Apple's.

Previous 1 2 Next