3 Replies Latest reply: Apr 2, 2014 10:59 AM by léonie
bob3052a Level 1 Level 1 (0 points)

I currently run 10.4 on an older Intel iMac and need to upgrade to 10.6.  However, I have software such as Aperture 2 and Microsoft Office that I would rather not have to replace.


iMac