6 Replies Latest reply: Apr 3, 2014 4:14 PM by Linc Davis
JimTinCT Level 1 Level 1 (0 points)

I installed the update yesterday and ever since Safari is quite problematic.

  • window won't close, minimize
  • all print requests from yesterday coming back as if I just submitted them
  • clear history grayed-out

 

Hopefully, a fix to the update will be available soon. Fortunately there are alternative browsers which are more stable (which is how I am able to pst this message.

 

Am I missing something re: the Safari issues?


OS X Mavericks (10.9.2)
  • Carolyn Samit Level 10 Level 10 (95,985 points)

    No issues with Safari 7.0.3 on v10.9.2 here ...

     

    Try deleting the cache associated with Safari.

     

     

    Open a Finder window. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Caches/com.apple.Safari/Cache.db

     

    Click Go then move the Cache.db file to the Trash.

     

    Quit and relaunch Safari to test.


     

    If that didn't help, you may have a Safari extension or third party plug-ins installed that was compatible with the prior version of Safari but not 7.0.3.

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

     

    If it's not an extensions issue, try troubleshooting third party plug-ins.

     

    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

     

     

    messaged edited by:  cs

     



     


  • JimTinCT Level 1 Level 1 (0 points)

    Hi Carolyn,

     

    Thanks for the comprehensive reply. I tried the first suggestion but did not have a

    ~/Library/Caches/com.apple.Safari/Cache.db file. Searched in three ways, first as you suggested, then went manually to the in the Library/cache folder and finally tried  a Spotlight search. Would the lack of that file cause problems?

  • Carolyn Samit Level 10 Level 10 (95,985 points)

    Make sure the ~ (Tilde) character is input before the first forward slash   ~/

     

    That file should be there.


     

     

    Mac OS: About Folders, Directories, and Pathnames

  • JimTinCT Level 1 Level 1 (0 points)

    Did a cut and paste from your message so the tilde was there. Alas, the file is not.

  • Carolyn Samit Level 10 Level 10 (95,985 points)

    Let's skip that for  the time being..

     

    Follow the instructions for troubleshooting Safari extensions and plug-ins posted previously on this thread please.

  • Linc Davis Level 10 Level 10 (159,235 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, by a peripheral device, by a font conflict, or by corruption of the file system or of certain system caches.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards, if applicable. Start up in safe mode and log in to the account with the problem. You must hold down the shift key twice: once when you turn on the computer, and again when you log in.

       

    Note: If FileVault is enabled, or if a firmware password is set, or if the startup volume is a Fusion Drive or a software RAID, you can’t do this. Ask for further instructions.

     

    Safe mode is much slower to start up and run than normal, with limited graphics performance, and some things won’t work at all, including sound output and Wi-Fi on certain models. The next normal startup may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, restart as usual (not in safe mode) and verify that you still have the problem. Post the results of Steps 1 and 2.