9 Replies Latest reply: May 3, 2014 9:35 PM by kevin_
_aperture Level 1 Level 1 (0 points)



I am having several connection issues with my home WiFi from my retina MBP. I think the issues started with either 10.9.1 or 10.9.0. There are two symptoms:

  1. When I start my Mac it takes several minutes before connecting to the netwrok. It seems to find the network (with strong signal) and it has been marked as a trusted network/connect automatically, but connection takes a long time and sometimes I have to manually select again for it to connect
  2. Whenever the Mac goes to sleep, it fails to reconnect to the network on waking up. Most of the times, I have to manually select it from the list again


Has anyone experienced/experiencing this problem? Any help will be greatly appreciated!




  • Grant Bennet-Alder Level 9 Level 9 (54,330 points)

    For help with WiFi Issues, please post the values you get when you hold down Option and Click the WiFi Icon in the menuBar. Looks like this:






    PHY Mode



    Transmit Rate


    Number of Networks visible (not counting your own)



  • _aperture Level 1 Level 1 (0 points)

    here is the screen shot... "Hole Universe" is my trusted secure home network.

    Screen Shot 2014-04-05 at 6.16.04 AM.png


  • Grant Bennet-Alder Level 9 Level 9 (54,330 points)

    • At -43 you have a good strong signal.

    • You are using 802.11n, capable of speeds as high as 600 Mbits/sec on a clear channel, close by, with no interference.

    • Channel 11 is in the crowded 2.4 GHz band, and that is likely where all your neighbors are as well. Also baby monitors, Microwave ovens, BlueTooth devices, and some cordless phones.

    • A transmit rate of 130 indicates a fair amount of your data are getting through (otherwise it would slow down more for better reliability)


    The Bad news: there are only THREE Clear Channels in that band -- fewer if you use 802.11n. So you are likely talking on the same channel as at least one of your neighbors.




    One way to get better connectivity and better speed is to replace your Router or add on with a dual-Band Router, which would also get you 8 to 12 more channels in the 5 GHz band, and better speeds.




    You should make sure that the Network you want to join is FIRST in list here, and use the Minus button to remove extraneous networks:





  • Linc Davis Level 10 Level 10 (177,970 points)

    Test after taking each of the following steps that you haven't already tried. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved. Make sure the box marked

    Remember networks this computer has joined

    is checked.

    2. Follow the instructions in this support article under the heading

    Symptom: After restarting or waking from sleep, my computer might not connect to the Internet

    3. Reset the PRAM.

    4. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    5. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    6. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    7. Repair permissions on the startup volume.

    8. Turn off Bluetooth and test.

    9. Reset the System Management Controller.

    10. This step shouldn't be necessary, but has been advised by Apple Support in some cases, apparently as a workaround for a bug. Open the Energy Saver pane in System Preferences. If applicable, click the padlock icon in the lower left corner to unlock the settings. Enter your administrator login password when prompted.

    Select the Power Adapter tab and uncheck the boxes marked

    Wake for Wi-Fi network access


    Enable Power Nap...

    if present. Then, if the computer is a MacBook, select the Battery tab and uncheck

    Enable Power Nap...

    11. Reinstall OS X.

  • _aperture Level 1 Level 1 (0 points)

    Thank you for the reply. My router is anyway up for an upgrade; guess I should do that and see. I have a few years old Airport Extreme currently! I am looking at one of these: http://amzn.com/B00DB9WCR6 or http://amzn.com/B00EXK14S0. Which one would you recommend? Or is there another model that may be even better?



  • Grant Bennet-Alder Level 9 Level 9 (54,330 points)

    I just bought an Airport Extreme through the Apple refurb store for US$169. plus tax.


    My speed increased 5 fold because I could move to the high band and use the full 802.11n. It is running at 300 Mbits/sec in the 5Ghz band, where you are getting 130 in the 2.4GHz band.


    Refurbished Airport Extreme

  • _aperture Level 1 Level 1 (0 points)

    I finally bought a new Airport Extreme 802.11ac and replaced my old one. With the new design and antenna positions I was expecting the overall signal strength to be stronger and range to be better. But on the contrary everything seems to have deteriorated drastically. Here is the new WiFi


    Here are the signal details when my MBP is 3 feet from the AE:

    WiFi 1.png


    Here are the singal details when my MBP us 15 feet from the AE:

    WiFi 2.png


    What may be the issue? Do I have a defective piece?


    thanks for your help,


  • Grant Bennet-Alder Level 9 Level 9 (54,330 points)



    RSSI of -74 at that range (unless the signal is shooting through a solid brick wall) is surprisingly bad signal strength.


    My Mac Pro 42lb tower, from inside an aluminum enclosure, 15 feet from the Base Station through two plaster walls backed by grounded wire lath gives a receive signal strength of -58, far higher (closer to zero are stronger) than your MacBook Pro.


    I think you (alone on this thread) should have your MacBook checked for a disconnected or damaged antenna.

  • kevin_ Level 4 Level 4 (1,535 points)

    I had a similar issue, and it took awhile to figure it out.  I believe that this has to do with Power Nap and a conflict between wifi and a bloothooth pref setting.



    Here is what I did to resolve the issue:

         1. Disable Power Nap in the Energy Saver prefs

         2. If you have a plist editor delete the entry for LastA2DPDevice in the com.apple.Bluetooth.plist


                  To make this step easier you can use the following command in the Teminal.

                       sudo defaults delete /Library/Preferences/com.apple.Bluetooth LastA2DPDevice

         3. Restart your Mac

         4. Re-enable Power Nap in the Energy Saver prefs