1 Reply Latest reply: Apr 6, 2014 9:08 AM by Chris CA
whitleyann Level 1 Level 1 (0 points)

i am unable to update my itunes. it is saying that my version (10.6.3) is the current version. when i go to plug in my iphone 5, it will not connect to itunes unless my itunes has been updated to 11.1

i went and tried to download the updated itunes from the website, but it says that i am unable to download it. please help!


iMac, Mac OS X (10.5.8)