2 Replies Latest reply: Jul 8, 2014 1:04 PM by TheOn3LeftBehind
Neal Jackson Level 1 Level 1 (75 points)

I've recently bought an iPad Air 16Gb Wi-Fi only. I have been unable to link to and play my Shared iTunes Library from my MacPro on my iPad Air using Apple's Music.app. When I select the Shared Library a wheel icon spins, taking around 15 minutes to complete as it loads the library data (Nothing is available to play until this process has completed). If I select anything to play; i.e., Album, track, etc., the play/pause symbol simply flickers madly between play and pause for a few seconds and then the app just stops. There is no movement of the track progress bar, no sound, nothing. No track is selectable and playable. Each alternative, new track just flickers between play/pause without doing anything.

 

I have been completely unable to access and play the music from the shared library on my MacPro with Music.app. The Music.app will work if I transfer a few tracks over and play them from within the app. My iTunes library, however, has over 35,000 tracks transferred from CD using Apple Lossless I can obviously only download several Albums to my iPad at a conversion rate of 256kbps.

 

Music Match is no use to me as I don't take my iPad outside the house and it doesn't have cellular capability anyway. I'm never more than 10M from a Wireless router so signal strength is not the problem as I can watch streamed HD movies in the garden. I just cannot play or listen to streamed shared iTunes Library music.

 

Anyone know what the problem is/may be and how I can fix it?

 

Thanks.


Mac Pro, OS X Mavericks (10.9), nVidia 780GTX and SSD Fusion drive
  • jason269 Community Specialists Community Specialists (4,085 points)

    Hello, Neal. 

     

    Thank you for visiting Apple Support Communities. 

     

    I see that you are only experiencing this issue with music and not movies.  Here are some steps that I would recommend starting with that I attached from the article below.

     

    4. Check your network connection

    Home Sharing requires a home network with an active Internet connection. All the devices you want to use with Home Sharing need to be connected to your home network.

    In addition, verify that:

    • All your devices are connected to the same router, if you have multiple routers. Using multiple routers may prevent discovery between these devices.
    • Your devices are not using a Virtual Private Network (VPN), or that they are all on the same VPN. A VPN may isolate the device and cause connectivity disruptions.
    • If you have a router set up with a guest network, make sure all devices are either connected to the guest network and devices on the guest network are allowed to communicate with each other, or switch all devices to the primary network on your router.
    • If your computer is asleep or shutdown, or iTunes is closed, there's no access to the shared iTunes library. Wake up or start the computer and open iTunes to regain access to that library.
    • Your router needs to be up-to-date. If you are using an AirPort or Time Capsule, learn about firmware updates. If you are using a router from another manufacturer, contact the manufacturer to inquire about available updates.

    5. Check Firewall settings

    If you have a firewall enabled in your router or computer, make sure that the firewall is not blocking communication between your computers. Home Sharing uses TCP port 3689 and UDP port 5353 to communicate with shared iTunes libraries.In addition, Apple TV and Mac computers will use port 123 to set the time automatically. Incorrect date and time on either the computer or Apple TV can cause errors for Home Sharing and connections in general.If you are unsure whether your router has a firewall or the required ports open, test additional devices or another network to help isolate the issue. If the devices tested work on another home network, it is your router or network configuration.For Mac OS X, you don't have to edit the port addresses, but make sure the firewall in Apple () menu > System Preferences > Security > Firewall are not set to:

    • Block all incoming connections
    • Allow only essential services

    If you use another security/firewall software on your computer or router, follow this article or contact the manufacturer or check the documentation on how to open TCP ports 123 and 3689 as well as UDP ports 123 and 5353.

    For more information on ports used by Apple products, see Well known TCP and UDP ports used by Apple software products.

     

    Troubleshooting Home Sharing

    http://support.apple.com/kb/ts2972

     

    Cheers,

     

    Jason H. 

  • TheOn3LeftBehind Level 1 Level 1 (15 points)

    Thank your or the mentioning the firewall settings, Jason!  I use Norton on my Mac and had to go to the connection blocking configuration in firewall settings, allow iTunes, click the plus sign next to iTunes, change block to allow, and select "allow all computers on this network" or whatever to allow access. It worked like a charm for me.