3 Replies Latest reply: Apr 10, 2014 3:31 AM by maasailand giraffe
maasailand giraffe Level 1 Level 1 (5 points)

I have an iPad Mini + cellular.  My wife has an iPad 2 + cellular.  Both are running iOS 7.0.6 (after reports of 7.1 maybe decreasing battery life, I’m waiting for 7.1.x).

 

Recently they both have developed the same problem.  If you turned on the hotspot, neither the MacBook, the MacBook Pro, nor the Apple TV could “see” it.  Going through the whole rigmarole of resetting everything under settings didn’t help.  Occasionally, rebooting the iPad in question would temporarily solve the problem, but not always.

 

Because of where we live, our cellular network is the only available internet, so this problem is really annoying.

 

We read somewhere about Apple collaborating more closely with the fat telecoms to prevent “illegal usage” of hotspots.  (Com’on, if you’re paying for data you’re paying for data and should be able to use it!  grumble, grumble)  So we figured out to go to Settings / Cellular Data / APN Settings, and scroll down to “Personal Hotspot,” click “Rest Settings” / “Yes” (or “Okay”), and fill in the extra login info from our provider.

 

Then we turn off cellular data and the personal hotspot, wait a few seconds, and turn them back on.  That works.  Sort of.  Sometimes.

 

But it doesn’t work for very long.  Sooner or later, the connected device thinks it's still connected, but the iPad is no longer sharing connectivity beyond itself.

 

It does not matter if bluetooth is on and wireless is off, or if bluetooth is off and wireless in on, or if they are both on, or even if they are both off and a computer is tethered with a USB cable.  We’ve tried every possible combination.

 

It also doesn’t matter if we keep the iPad awake or keep the personal hotspot settings page open on top.

 

When either iPad is acting up like this, I’ve noticed that the blue notification bar at the top of the screen telling whether anyone is connected comes and goes.  Even when it’s not there, a connected Mac thinks it’s still connected, but there’s no functional connectivity.

 

Any help?


iPad mini Wi-Fi + Cellular, iOS 7.0.3
  • maasailand giraffe Level 1 Level 1 (5 points)

    More info:

     

    When one of the Macs thinks it’s connected to one of the iPads, and the blue notification bar is doing its on and off thing, Dropbox gives it's status as online.  But browsers and Mail give “server cannot be reached” error messages.  With the MacBook Coonection Doctor, the connection status is “Mail was able to connect to the Internet.”  Consequently, the Network Diagnostics button is greyed out.  But the individual email accounts are all unable to connect to their servers.

     

    If I drive into town and use someone’s wifi, the mac has no problem, which confirms that the iPads do have a problem.

  • maasailand giraffe Level 1 Level 1 (5 points)

    I forgot to mention:  going to Settings > General > Reset > Reset Network Settings hasn’t solved this issue.

  • maasailand giraffe Level 1 Level 1 (5 points)

    Fixed!

     

    Two things together have restored connectivity.

    1.  I changed the name under Settings > General > About > Name from My Name's iPad to iPad of My Name.  I read somewhere that iOS 7.0.1 or 7.0.2 (I forget which) sometimes had issues with apostrophes here.  Easy enough to test.

    2.  I then reset (again) the APN settings under Settings > Cellular Data > APN Settings > Personal Hotspot and reentered our provider's info (APN, Username, Password) there.

     

    I don't know WHY it worked, but the personal hotspot is now happily sharing (again) internet connectivity with my MacBook Pro.