3 Replies Latest reply: Apr 8, 2014 2:34 PM by randers4
antijohnny Level 1 Level 1 (0 points)

cannot log into icloud with my apple id on my macbook. says wrong id


MacBook Pro, Mac OS X (10.6.8)
  • antijohnny Level 1 Level 1 (0 points)

    it also says in my account that my mobile me name has been set. I never set anything. I have no idea what the name is if so

  • randers4 Level 9 Level 9 (62,585 points)

    iCloud requires OS X 10.7.5 or higher.  Are you running 10.6.8 as it says in your profle?

  • randers4 Level 9 Level 9 (62,585 points)

    MobileMe was closed over a year ago and was replaced by iCloud.  Even though you still have that setting it will no longer function.

     

    You will need to upgrade to OS X Lion higher in order to set up iCloud on your Mac.  First check to see if your system meets the system requirements to upgrade.

     

    Lion system requirements are:

     

    • Mac computer with an Intel Core 2 Duo, Core i3, Core i5, Core i7, or Xeon processor
    • 2GB of memory
    • OS X v10.6.6 or later (v10.6.8 recommended)
    • 7GB of available space

     

    Mountain Lion and Mavericks requirements are the same, as listed here: http://support.apple.com/kb/HT5842.

     

    If you can run Mavericks, you can download a free upgrade from the Mac App Store.  If your system can only run Lion, you can go here to purchase a redemption code to download it from the Mac App Store.  If you prefer Mountain Lion for software compatibility reasons, you can go here to purchase a redemption code to download it from the Mac App Store.

     

    After upgrading, you will find iCloud in System Preferences>iCloud on your Mac, and can set it up as explained here: http://www.apple.com/icloud/setup/mac.html.

     

    Before upgrading, you may want to check the compatibility of your existing applications by checking here: http://roaringapps.com/apps:table.   Also be aware that older PPC programs such as AppleWorks and Office 2004 for Mac will not run on OS X Lion or higher.