Previous 1 2 3 4 Next 46 Replies Latest reply: Apr 2, 2016 3:03 AM by Abu Hajar
Shellytrep Level 1 Level 1

How do I change the phone number associated to my keychain for ICloud?


iPhone 4S, iOS 7.0.4
Reply by Ahhmt on Nov 24, 2014 7:14 AM Helpful

I think you may still get it to work. If I recall correctly it's when you are asked to enter the code, below the boxes where your code would normally go, there's a "Forgot code" option or something to that effect.  When you click that, I think you'll be given the option to reset.

Reply by solomani on Nov 24, 2014 2:46 PM Helpful

Ahhmt!  You are the winner!  Thanks for that, finally got it all working now after hitting my head against a brick wall the last few weeks trying to change that phone number.  Thank you.

Reply by dusanp83 on Nov 8, 2014 11:50 AM Helpful

Hi everyone,

 

I just have same problem, but i found a solution....

 

On iOS go to Settings > iCloud > Keychain and tap to button to disable iCloud Keychain. (you will be asked to delete or keep passwords on device) i chose delete....

 

Then enable it again and in pop-up chose Reset iCloud Keychain, on confirmation pop-up chose Reset

 

In new pop-up  Use iPhone Passcode as iCloud Security Code? chose Use Passcode

 

Enter your passcode (4 digit) and then chose country and your new phone number

 

And done!


I just changed my number on Iphone 4, 7.1.2

All replies

  • Kilgore-Trout Level 7 Level 7
    expertise.ipad
    iPad

    Assuming you mean autofil, it comes from the Contact Entry in contacts that you have designated as you. Settings App > Safari > Passwords and autofill.

  • fromsouth Level 5 Level 5
    expertise.icloud
    iCloud
    • Devices using iOS 7.0.3 or later: Tap Settings > iCloud > Account, then tap Keychain. Check that the phone number listed under Verification Number is correct. If not, enter another phone number.
    • Macs using OS X Mavericks v10.9 or later: Choose Apple () menu > System Preferences. Click iCloud, then click Account Details. Check that the phone number listed under Verification number is correct. If not, enter another phone number.

    http://support.apple.com/kb/TS4644

  • hpmarcus Level 1 Level 1

    This does not work.

     

    - When using the iOS way the screen Settings > iCloud > Account > Keychain shows "approve with security code" grayed out. No telephone number anywhere.

     

    - When using Apple () menu > System Preferences > iCloud > Account Details, there is no option to change anything at all. You can, however, go to "Manage Apple ID" and change your phone number. Even so, the SMS code is still being sent to the wrong number.

  • fromsouth Level 5 Level 5
    expertise.icloud
    iCloud

    hpmarcus wrote:

     

    This does not work.

     

    - When using the iOS way the screen Settings > iCloud > Account > Keychain shows "approve with security code" grayed out. No telephone number anywhere.

     

    - When using Apple () menu > System Preferences > iCloud > Account Details, there is no option to change anything at all. You can, however, go to "Manage Apple ID" and change your phone number. Even so, the SMS code is still being sent to the wrong number.

    Thanks for letting me know.

  • xcelin Level 1 Level 1

    So does actually anyone know how to change it ???

  • Zoroo84 Level 1 Level 1

    Yes, how to change it? In Settings > iCloud > Account > Keychain I do  not have any option to change and my security code always go to a number that i do not have anymore...

  • dusanp83 Level 1 Level 1

    Hi everyone,

     

    I just have same problem, but i found a solution....

     

    On iOS go to Settings > iCloud > Keychain and tap to button to disable iCloud Keychain. (you will be asked to delete or keep passwords on device) i chose delete....

     

    Then enable it again and in pop-up chose Reset iCloud Keychain, on confirmation pop-up chose Reset

     

    In new pop-up  Use iPhone Passcode as iCloud Security Code? chose Use Passcode

     

    Enter your passcode (4 digit) and then chose country and your new phone number

     

    And done!


    I just changed my number on Iphone 4, 7.1.2

  • Ahhmt Level 1 Level 1

    This worked for me.  Although, to "Reset iCloud Keychain," I assumed meant to clear the data and essentially set up a new, blank Keychain.  Not so.  Strangely, after essentially bypassing the security regimen, setting a new passcode and verification number, I see my cards, passwords and other data have been restored.  Maybe it's all about the iCloud account and that master password.  Or maybe it's a bug.  With Apple, we'll never know.

  • solomani Level 1 Level 1
    expertise.macosx
    Mac OS X

    I am stuck as well.  My  keychain keeps trying to send a verifcation to a phone I no longer have access to (moved countries).  Even if I put my access code in. 

     

    How can I change this under OS X Yosemite?  I have changed it online already but doesn't seem to have any relation to my iMac.

  • Ahhmt Level 1 Level 1

    dusanp83's solution worked for me.  maybe give that a try?

  • Zoroo84 Level 1 Level 1

    "On iOS go to Settings > iCloud > Keychain and tap to button to disable iCloud Keychain. (you will be asked to delete or keep passwords on device) i chose delete...."


    I will NOT be asked and cannot delete unfortunately. Using iphone 6 IOS 8.1.1. Any further solution?

  • solomani Level 1 Level 1
    expertise.macosx
    Mac OS X

    >dusanp83's solution worked for me.  maybe give that a try?

     

    No good because all my devices are already off, so turning it off is not an option and if I turn it on it asks for my code and then sends an SMS to my old phone.

  • Ahhmt Level 1 Level 1

    I think you may still get it to work. If I recall correctly it's when you are asked to enter the code, below the boxes where your code would normally go, there's a "Forgot code" option or something to that effect.  When you click that, I think you'll be given the option to reset.

  • solomani Level 1 Level 1
    expertise.macosx
    Mac OS X

    Ahhmt!  You are the winner!  Thanks for that, finally got it all working now after hitting my head against a brick wall the last few weeks trying to change that phone number.  Thank you.

Previous 1 2 3 4 Next