14 Replies Latest reply: Apr 25, 2016 8:42 AM by mryeeguy
graemefromwimbledon Level 1 Level 1

Upon installing Mavericks, and turning on iCloud keychain, I noticed that all wifi networks I had ever connected to appeared in the preferred network list on my Macbook.

There were quite a few I naturally wanted to delete, so I removed them. Also my devices were trying to connect to networks I thought I had removed.

 

It didn't take me long to notice that my Macbook was trying to connect to some of these old networks again, and upon looking at the list - all deleted entries had reappeared.

Another symptom seems to be that if I tell my iPhone not to auto-connect to a public hotspot (BT WIFI for example), if my Mac ever comes near that hotspot it auto connects - as will my iPhone subsequently.

 

I have tried editing the com.apple.airport.preferences.plist file manually, deleting the Mac's WiFi service and recreating, and resetting network settings on all my Apple devices.

I have even looked at the Keychain app on my Mac, but it doesn't seem to be storing my wireless networks from what I can see.

 

From my Google-ing, it doesn't sound like anyone else is having this issue..

 

Any ideas?

 

Thanks!


MacBook Pro (Retina, 13-inch, Early 2013), OS X Mavericks (10.9.2)
Solved by graemefromwimbledon on Apr 17, 2014 5:54 AM Solved

For the benefit of anyone who happens across this article, I may have found a solution.

 

It looks like the local keychain may be conflicting with the iCloud one. If this is the case though, no amount of editing/repairing the keychain resolved it for me.

 

To that end, I logged out of iCloud in settings, then logged into another profile (an Admin) and deleted my user account - retaining the Home folder in its current location (I navigated to the home folder and renamed it to remove 'deleted' from the end to facilitate the next step).

I then recreated my profile, and pointed it to the retained Home folder from my old profile. Note that the home folder and profile name must match.

 

When I logged in, everything was exactly as I had left it - I logged back into iCloud, and was up and running in minutes. All the caches and keychains from the old profile seem to have been deleted, but if you use iCloud keychain, it will all restore properly.

 

The whole process took about 10 minutes, and the network error has not come back in the last 5 days.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    In the Wi-Fi network settings, uncheck the box marked

    Remember networks this computer has joined

    and test.

  • graemefromwimbledon Level 1 Level 1

    I tried that too.

     

    The majority of networks appearing are ones I have used on my mobile devices.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    Back up all data. Open the iCloud preference pane and uncheck the Keychain box. You'll be prompted to delete the local iCloud keychain. Confirm. Also disable it on the other devices. Delete the unwanted preferred networks from all devices. Then follow one of the procedures described in this support article to set up iCloud Keychain.

  • graemefromwimbledon Level 1 Level 1

    I've tried that too.

    I went as far as to sign out of all iCould on all devices, delete the network plist files on the Mac and reset network settings on all iDevices, then signed in again.

    It appeared to work at first, but a day or two later the old hotspots reappeared on the mac list.

     

    My two theories are:

     

    Deleting preferred networks doesnt remove them from iCloud, and the next time you make a change on any device iCloud restores them on the list on the Mac.

     

    Second idea is that there is another location on the Mac that stores the preferred networks, and it is overwriting my list.

     

    I suspect its the first option. I have also noticed that stored passwords in the iCloud keychain reappear after being deleted, however I would have expected other users to notice this problem..

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    iCloud Keychain stores its data in a subfolder of ~/Library/Keychains with a long, random name. If you want to experiment with deleting that folder, you'll know more about the subject than I do. The internals of the service are undocumented.

  • graemefromwimbledon Level 1 Level 1

    For the benefit of anyone who happens across this article, I may have found a solution.

     

    It looks like the local keychain may be conflicting with the iCloud one. If this is the case though, no amount of editing/repairing the keychain resolved it for me.

     

    To that end, I logged out of iCloud in settings, then logged into another profile (an Admin) and deleted my user account - retaining the Home folder in its current location (I navigated to the home folder and renamed it to remove 'deleted' from the end to facilitate the next step).

    I then recreated my profile, and pointed it to the retained Home folder from my old profile. Note that the home folder and profile name must match.

     

    When I logged in, everything was exactly as I had left it - I logged back into iCloud, and was up and running in minutes. All the caches and keychains from the old profile seem to have been deleted, but if you use iCloud keychain, it will all restore properly.

     

    The whole process took about 10 minutes, and the network error has not come back in the last 5 days.

  • P Diddy Level 1 Level 1

    Hi

     

    I have been battling the same problem.  So far, the only solution I have found is to log all devices off iCloud Keychain and then rebuild them one by one without restoring backups. 

     

    I tried the method of creating a new user account, which worked for a few hours, and then the old preferred networks came back again.  I think they came back when a different user logged on to the Mac.  I don't think I can take deleting each user account in turn (we have five accounts per Mac), it will be easier to just wipe the machines and start again.

     

    Does anyone else have any ideas as to how to delete preferred networks once and for all?

     

    Thanks

     

    PD

  • P Diddy Level 1 Level 1

    I have worked out what was causing the old wifi networks to reappear.  I have user accounts for each member of the family (5 of us).  What I had to do was turn off iCloud keychain for every user on every computer, delete wifi networks for every user on every computer, then reset everyone's iCloud keychain, and then turn iCloud key chain back on for every user... on every computer.

     

    I have been running now for 3 months with no more old wifi networks reappearing.  It would be nice if when you deleted a wifi network, it actually got deleted.

     

    Cheers

     

    PD

  • stynz Level 1 Level 1

    Hi.

    Could you explain how did you reset everyone's iCloud keychain? Is the problem definitely solved or it reappeared?

    thanks

    MS

  • P Diddy Level 1 Level 1

    The problem has reappeared

     

    I reset everyone's iCloud Keychain by resetting the unlock code.

  • MacProse2015 Level 1 Level 1

    Did anyone figure out a permanent solution to keeping deleted preferred WiFi networks from reappearing?

  • bongoherbert Level 1 Level 1

    Here's a fun detail / observation. It seems like the iCloud keychain is remembering and syncing all networks joined across the whole family. I have literally hundreds of networks in my preferences. I have successfully deleted / reset them using each and every solution posted above, and have experienced exactly all the recurrence / etc listed in this thread. They'll be gone for a while, but magically re-appear. Usually some subset.

     

    Also note that some members of my family  have apparently logged in to wifi networks that I never have yet provide details of them being in places that maybe they wouldn't want me/other family members know about. For example, imagine that the network "Lola's Massage and More" gets logged in to 'accidentally' on a family member's iPhone / Mac and everything sync up and boom now everyone in the family knows!

     

    I also seem to have some networks that I have logged in to years ago that I cannot get to disappear (conferences, hotels, etc).

     

    Finally, some of us have different 'preferred orders' of logging in because we work / live in different places sometimes. This also seems to get messed up.

     

    This is starting to get a little nutty.

  • olteanra Level 1 Level 1

    Here's the way you can manage your saved networks on your Apple mobile devices. This requires a Mac to be able to select which saved Wi-Fi networks you wish to keep and which ones you wish to remove.

     

    1. Make sure you have a Mac that is connected to and has the Keychain sync'ed to the same iCloud account as all of the mobile devices (iPads, iPhones) you are trying to remove redundant saved Wi-Fi networks from!!!
    2. On ALL of your iPads and iPhones connected to that iCloud Account turn off iCloud->Keychain in Settings and select Delete all from my iPad/iPhone when asked, so that all Passwords and Credit Cards are removed from your local iPhone/iPad storage and brought back later on from iCloud. Next, go to Settings -> General -> Reset and Reset Network Settings so Network Settings (saved Wi-Fi networks) are also deleted and brought back later on from iCloud.
    3. Go to your Mac and remove the unwanted saved Wi-Fi networks from Settings -> Network -> Advanced... then hit OK and Apply. At this point your Mac should start sync'ing the updated saved networks list to your iCloud account and remove all of those networks as requested.
    4. Go back to your mobile devices and re-enable iCloud->Keychain in Settings. You'll have to confirm the Keychain enablement for each mobile device on your Mac (or other device connected to that iCloud account) before your mobile device is allowed to sync.
    5. Now you should have all of your Networks, Passwords and Credit Cards back on your mobile devices. You can confirm that your Passwords are back in Settings -> Safari -> Passwords and your Credit Cards in Settings -> Safari -> AutoFill -> Saved Credit Cards.
    6. All you still need to do is re-enable AutoFilling for Names and Passwords and Credit Cards in Settings -> Safari -> AutoFill, because for some reason iOS disabled these when you chose to disable Keychain syncing with iCloud.

     

    You have to do all of the above because most likely there is a bug in Apple's Keychain sync'ing logic. Normally, if you removed a bunch of saved networks from one device, the removal should be applied to all of the other devices connected to that same account, but it's not! Instead, the other devices push back the missing saved networks to that one device you removed them from.

     

    I really needed to remove a lot of saved networks from my Apple devices because I've gathered about 100 of them in time and it took about 13 seconds for any of my Apple devices to connect to any Wi-Fi network at that point. After removing all of the unwanted networks, I was left with about 10-15 networks that I actually needed and now my Apple devices take about half a second to connect to any of those networks.

  • mryeeguy Level 1 Level 1

    There's a way to remove the iCloud Keychain (in the cloud) without deleting your entire user account.

    https://support.apple.com/en-us/HT204085

     

    Use iCloud Settings and turn off iCloud Keychain *and* be sure to turn off Approve With Security Code (that's apparently the setting that enables Apple to keep a copy of all your previously joined wifi networks in the cloud).  If you turn off iCloud Keychain and Approve w/ Security Code, and then Reset iCloud Keychain, that should get rid of your unwanted list of wifi networks.  After that, re-enable iCloud Keychain and make sure that the Approve w/ Security Code setting stays off.  You'll need to approve the addition of each new device to your iCloud Keychain from another device, but that's pretty straightforward.

     

    Good luck!