12 Replies Latest reply: Aug 11, 2014 1:14 PM by xnuzboss
mr.bill Level 1 Level 1 (15 points)

Hello- I have a keynore presentation that has a recorded timing. Everything looks fine with the presentation until I try to export to QT. The QT export version is much much shorter. Thus, it looks like the timing is very different in the export than the viewing version(s).

 

Anyone else run into this and if so, any work arounds?

 

Thx.

  • chilerelleno Level 1 Level 1 (0 points)

    Hey Mr. Bill,

     

    I'm having the same issue here as well with Keynote 6.2.

     

    I also note changes in recorded timing when ".key" file is shared between devices (i.e. Mac, iPhone, iPad). I've tested this issue by editing the recorded timing on iPad and iPhone with no luck in controlling the actual presentation timing. The presentation seems to ignore the timing I set to each slide when the presentation is played. However on preview of a "transition", timing displays correctly.

     

    Weird stuff that I have no idea how to workaround or correct. Anyone have any ideas?

     

    Message was edited by: chilerelleno

  • chilerelleno Level 1 Level 1 (0 points)

    Prior to exporting your presentation to Quicktime or another file type, be sure to adjust "Presentation Type" settings for Delays (ie Transitions and Builds).

     

    For Keynote 6.2 navigate to the Document icon in far right corner of main menu. See Presentation Type. Select "Self-Playing" and adjust delays for Transitions and Builds prior to export to QT.

     

    Hope this helps!!!

  • mr.bill Level 1 Level 1 (15 points)

    Hello- Ok, I've logged over 42hrs working on this bug... Its a nasty one, but I think I've found the issue. I've yet to fully test this, but here's what I've found....

     

    A bit of background 1st:

    - I'm using keynore to generate annimations for video. Keynote is an awesome tool for this.

    - The video has a sound track with voice overs which makes timing a critical issue

    - The be able to export this as a video, I have to record narration, but I choose an input channel that has no audio in (such as Sunflower 2ch). This enables me to export as a recorded timing with the sountrack. As a result, its a full blown video annimation application

     

    The issue I was having is the following:

    - Viewing the video within Keynote works great. As soon as I export to quicktime, the timing is way off... I'm talking like over a 1 minute in a 3 minute video.

     

    Here's what I think is causing the problem:

    - Adding an 'il-timed' quicktime movie within Keynote (yes, keynote will export your quicktime movie within the exported quicktime movie- very cool!)

    - Ill timed means this: The movie time is longer than the slide time. Example: I add a 1 minute video, select a start and stop point in quicktime that makes the movie 30 seconds, but set the slide time to 32 seconds.

    - Here's what Keynote does in export: When you export it as a recorded timing QT movie, it exports as if the embedded QT movie is being fully played.

     

    Thus, slide timing is overridden by the embedded QT movie when you export to QT movie.

     

    I have to do further testing to confirm this, but it appears this is the problem.

     

    Hope all this makes sense. I'll report back once I really test this out.

  • mr.bill Level 1 Level 1 (15 points)

    Hey- Just an update. After a lot of trial and error, its definately an embeded QT movie problem. This feature used to work, but there must have been some update that broke this (total bummer!).

     

    Now, no matter what, when I add a quicktime movie and try to export as recorded movie, the timing is way off in the exported QT movie. I don't have a work around and have tried everything I can think of.. This is yet another blow to the world of Keynote and its past glory

  • Robert Breeding Level 1 Level 1 (5 points)

    Some comments on the "workaround" offered:

    1. When you export to QT the only option available is Self-Playing.
    2. The export dialog's default timing settings for slide durations and builds (5 secs and 2 secs) are intended for use when the presentation has "on-click" events. It says this right below these settings. The default settings are not supposed to apply to specified timing assigned to events.
    3. So, this is a serious bug.
  • Robert Breeding Level 1 Level 1 (5 points)

    I would not attribute this to an embedded movie. See my other posting in this topic. The QT Export feature in 6.2 appears to completely ignore transition, build and action timings on export and substitutes the 5-second slide transition and 2-second build transition defaults regardless of what you have set in your presentation. I am seeing this in a Keynote Presentation, designed to be output to video and played on a loop, that contains no audio, no embedded video, no media whatsoever.

  • Gary Scotland Level 6 Level 6 (10,680 points)

    When you export to QT the only option available is Self-Playing.

    There are two options in Quicktime Export; Self Playing which uses the timing set in the export dialogue box, and Slideshow Recording which uses the timing set in Play > Record Slide Show.

  • Robert Breeding Level 1 Level 1 (5 points)

    Gary, et al., I should have clarified this remark. The drop menu does contain two options, as Gary points out, but only one was enabled for selection - Self-Playing. The other was disabled.

  • Gary Scotland Level 6 Level 6 (10,680 points)

    only one was enabled for selection - Self-Playing. The other was disabled.

    A Slide Show Recording has to be made before this option is available:   Play > Record Slide Show

  • xnuzboss Level 1 Level 1 (0 points)

    I am working on this problem as well. The mission is to create narrated presentations in video for an online training portal. I've solved every problem except this one: When the Keynote file is exported as a QT video, the audio on the embedded videos plays back just ahead of the video, which is a VERY bad thing when using a clip of, say, myself to narrate a portion of the presentation. I make the movie in Photo Booth (or using ANY software), import it into Keynote, where it plays just fine, and then export the presentation to QT. Every time and no matter what the source of the embedded video in the presentation, the audio timing off just a bit. Can't make professional videos this way with Keynote. I use Self-Playing and zeroes on the timing options. Again, everything works great EXCEPT when embedded video with sound.  Does anybody have a solution?

     

    p.s. I'm trying to create an idiot proof method for making these presentations, for executives are creating them, not geeks. I don't want to go near iMovie, for example.

  • Gary Scotland Level 6 Level 6 (10,680 points)

    Can't make professional videos this way with Keynote.

     

    Images and sound contained in Keynote are not locked together, they will drift apart when playing, these errors are carried over when exporting to QuickTime. The only fail safe way to sync sound and visuals together is use an application that has a sync system, Fotomagico is the number 1, or as the end product is video, use a professional video editing application from the start, Final Cut Pro is Apples professional product.

  • xnuzboss Level 1 Level 1 (0 points)

    Gary, you won't believe the relief I felt after reading your response. I'm not crazy! Wow!

     

    I'm going to look at Fotomagico, but it looks a little too complicated for these executives, which means they'll make their presentations in Powerpoint, and I'll have to recreate them in Fotomagico or Final Cut or Adobe Premier. Oh well, job security.

     

    Thanks again, man. I hope Apple gives you a pat-on-the-back for this, because it's the very first time I've ever been totally helped by a user in these or any other tech forums. Thank you again,

     

    Terry