4 Replies Latest reply: Apr 10, 2014 9:38 PM by Swaggyb7
Swaggyb7 Level 1 Level 1 (0 points)

When I start my computer it recognize my password fine but when I log off or it goes to sleep it doesn't recognize my password anymore and it starts asking for keychains and stuff so I have to shut it down in order to login again, any help?Screen Shot 2014-04-09 at 11.43.38 PM.pngScreen Shot 2014-04-10 at 2.07.18 PM.png


MacBook Pro with Retina display, OS X Mavericks (10.9.2)
  • Swaggyb7 Level 1 Level 1 (0 points)

    I'm still facing the same problem

  • Linc Davis Level 10 Level 10 (150,525 points)

    Back up all data.

     

    Launch the Keychain Access application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Keychain Access in the icon grid.

     

    Select the login keychain from the list on the left side of the Keychain Access window. If your default keychain has a different name, select that.

     

    If the lock icon in the top left corner of the window shows that the keychain is locked, click to unlock it. You'll be prompted for the keychain password, which is the same as your login password, unless you've changed it.

     

    Right-click or control-click the login entry in the list. From the menu that pops up, select Change Settings for Keychain "login". In the sheet that opens, uncheck both boxes, if not already unchecked.

     

    From the menu bar, select

       

    Keychain Access Preferences First Aid

      

    If the box marked Keep login keychain unlocked is not checked, check it.

     

    Select

      

    Keychain Access Keychain First Aid

       

    from the menu bar and repair the keychain. Quit Keychain Access.

  • Swaggyb7 Level 1 Level 1 (0 points)

    Thank you man.