2 Replies Latest reply: Apr 26, 2014 1:30 AM by _Anno_
M.S.Bursheh Level 1 Level 1 (0 points)

My Internet is not working after installing "StarTech Thunderbolt Docking Station" driver although "Ethernet" and "wireless" say they're connected, still there is no internet.

 

I have bought a "StarTech Thunderbolt Docking Station" as I need to use 2 thunderbolt based pieces of equipment on my "MacBook Pro"; which are a 2nd monitor as well as a Thunderbolt driven Audio Interface.

 

When I first plugged all my equipment to the "StarTech Thunderbolt Docking Station" everything was working fine, all pieces of equipment worked as well as Ethernet from both the computer and the docking station were working perfectly.

 

However, when I inserted the "StarTech Thunderbolt Docking Station driver CD" and installed the drivers, the internet on my computer has stopped working. Although the Ethernet says it is "connected" (same goes for "Thunderbolt Ethernet" when cable is connected to it) still the internet does not work. Even my wireless internet is not working anymore. Furthermore, also after installing the Docking Station drivers, my iTunes is crashing whenever started.

 

Please help, this is really urgent.

 

I've been looking for answers all around but can't seem to find any.

I'm using OSX Mavericks 10.9.2

I've tried fixing stuff with Network preferences, like changing IP address, renewing DHCP leace.

I also tried typing IP address, Subnet Mask, Router and DNS Sever manually... Nothing seems to be working.

 

Note: I know someone could suggest to "uninstall" the Thunderbolt Station driver, however, I can't find an "uninstallation file", even the CD that came with the docking station does not have it.


MacBook Pro, OS X Mavericks (10.9.2)
  • Csound1 Level 8 Level 8 (40,565 points)

    Uninstall the Startech drivers, if you don't know how to do that ask Startech

  • _Anno_ Level 1 Level 1 (0 points)

    I had exactly the same problem today, and I was lucky enough to solve it.

     

    Here's what helped me:

     

    First, I found a hint to Suspicious Package in this thread.

     

    With Suspicious Package installed, I was able to identify the script in StarTech's installer pkg. It' called "postflight".

     

    Amongst other things, postflight runs this command:

     

    sudo mv usr/share/sandbox/mDNSResponder.sb usr/share/sandbox/_mDNSResponder.sb

     

    A quick check in Apple's knowledge base revealed, that the mDNSResponder is essential to use DNS (i.e. to resolve server names like www.apple.com) and bonjour.

     

    I moved th mDNSResponder back to where it belongs:

     

    sudo mv usr/share/sandbox/_mDNSResponder.sb usr/share/sandbox/mDNSResponder.sb

     

    After a reboot, everything worked fine again.

     

    I have no idea, why StarTeck disables an essential tool. Let's assume it's an error ...

     

    But after this experience, I didn't want the StarTech ethernet driver on my machine (I had installed it just for curiosity, anyway - yes, I know, I shouldn't have ...), so I removed the kext the installer had copied to my system:

     

    sudo mv /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleIntel8 2580.kext /Users/myusername

     

    (You see I didn't delete the kext directly, I just moved it away and tried another reboot. Now everything works fine, so I'm going to delete the kext entirely and paint a big red cross on StarTech's installer disk.

     

    Hope this helps.