3 Replies Latest reply: May 24, 2015 8:54 PM by jalovitrue
Ganelini Level 1 Level 1 (0 points)

After this last security update my mini doesn't remember passwords of the accounts, it used to ask me if I want safari to remember.., but no any more


iPad, iOS 7.1
  • jason269 Community Specialists Community Specialists (3,990 points)

    Hello, Ganelini. 

     

    Thank you for visiting Apple Support Communities.

     

    This sounds like you may have Private Browsing enabled.  The article below will show you how to disable this feature.

     

    Safari is not asking to save account names and passwords, even though iCloud Keychain is turned on.

    Devices using iOS 7.0.3 or later:

    1. Go to Settings > Safari > Passwords & AutoFill, then turn on Names and Passwords.
    2. Return to your Home screen and open Safari. If Safari is black or dark instead of white or gray, Private Browsing is turned on. Safari doesn't save account names and passwords when Private Browsing is turned on. To turn off Private Browsing:
      • On iPad, tap the the plus + symbol in the upper-right corner of the Safari page, then tap Private in the lower-left corner.
      • On iPhone and iPod touch, tap in the lower-right corner of the Safari page, then tap Private in the lower-left corner.

    Macs using OS X Mavericks v10.9 or later:

    1. Choose Safari > Preferences, then click AutoFill.
    2. Select the “User names and passwords” checkbox.
    3. Open the Safari menu and make sure there's not a checkmark next to Private Browsing. Safari doesn't save account names and passwords when Private Browsing is turned on.

    Safari isn't automatically filling in account names and passwords on some web sites.Devices using iOS 7.0.3 or later:

    1. Go to Settings> Safari > Passwords & AutoFill and make sure that these two settings are turned on:
      • Names and Passwords
      • Always Allow
    2. Return to your Home screen and open Safari. If Safari is black or dark instead of white or gray, Private Browsing is turned on. Safari doesn't save account names and passwords when Private Browsing is turned on. To turn off Private Browsing:
      • On iPad, tap the the plus + symbol in the upper-right corner of the Safari page, then tap Private in the lower-left corner.
      • On iPhone and iPod touch, tap in the lower-right corner of the Safari page, then tap Private in the lower-left corner.

    Macs using OS X Mavericks v10.9 or later:

    1. Choose to Safari > Preferences, then click Passwords.
    2. Make sure that that these two checkboxes are selected:
      • AutoFill user names and passwords.
      • Allow AutoFill even for websites that request passwords not be saved
    3. Open the Safari menu and make sure there's not a checkmark next to Private Browsing. Safari doesn't save account names and passwords when Private Browsing is turned on.

     

    iCloud: Troubleshooting iCloud Keychain

    http://support.apple.com/kb/TS4644

     

    Cheers,

     

    Jason H.

  • PSIpherOne Level 1 Level 1 (0 points)

    Okay,

     

    This my first "Fix-It Felix, Jr." post, so please bear with me.

     

    After a healthy couple of hours trying to figure this thing out, I came across a solution by a user on MacRumors.com.

     

    My problem: I had typed in the wrong password. So, it auto-filled the wrong password. I went to settings, and deleted the saved password and username. When I returned to fill in my info, Safari did not ask me if I wanted to save my username and password (hence, auto-fill). I deleted my cookies, history, etc. Puzzled and cross-eyed after the numerous searches and reading. I found a solution:

     

    1. Delete the the Username and Password in    'settings=>safari=>passwords & autofill=>saved passwords'

    Find the website, and delete the information.

    2. Go back to Safari at the site's login. Fill in your username and password. BUT, DO NOT click 'enter' or 'go' or 'whatever'.

    3. Click on the Refresh Button on the address bar (looks like a circling arrow).

     

    PRESTO!!!

     

    Good Luck!!!

  • jalovitrue Level 1 Level 1 (0 points)

    Thank you so much, your solution is the only thing working for me. To think that this was the only solution, this needs to be seen more and Apple really need to improve on this aspect. Cheers