2 Replies Latest reply: Aug 1, 2014 7:36 AM by alfiepercy
John Vezirian Level 1 Level 1 (0 points)

Ok there are several items on the forums about this but I cannot get this resolved.

 

Ever since the last update I cannot get Genius to function. I have tried everything.

 

I am running windows 7 64 bit, have about 9800 albums in my library, Genius just up and dissapeared, taking all my playlists with it.

 

I have tried to resolve the issue as follows.

 

  • Uninstalled iTunes, reinstalled.
  • Uninstalled everything and starting from scratch.
  • Shortened the directory
  • Cleaned all the alblum names, removing spaces and special characters

My music is on a separate drive, and it work on another computer and on another Windows 7 laptop, 64 bit laptop.

 

So I do not get it.

 

What is up.

 

I start genius and either get the server is busy message, or it fails, or it completes and then when I select genius, it dissapears.

 

This is just nuts........


iPhone 4S, Windows 7
  • John Vezirian Level 1 Level 1 (0 points)

    Well I did it, I completed the process of removing iTunes, cleare everything all my old playlists, I decided to start from scratch, just to be sure. I then added my music and movies back into iTunes and told it to manage all my files, make a copy on my media drive, then I removed the duplicates (old location) I still have back up copies on my big back up drive.

     

    So everything is in the iTunes media folder and the folder is on my media drive. lookes pretty clean. I opened iTunes, all is there and no playlists, so starting from clean slate.

     

    I turned on Genius and nothing, it gets as far sending the info, then it says it is taking a long time to send the info, then it comes back and tells me iTunes is busy, or the Apple Store is busy and check my internet connection, try again later. I have tried 15 times so far. My connection is fine, I am getting 30mbs download speed, 12mbs upload speed, latency ping at 19ms through my router, and it is hard connected, not using the wifi.

     

    I ma going to try a direct connection to the cable modem next and see if that works, as some one suggested that the firewall in my router may be an issue, but **** it worked before, this last **** update to iTunes.

     

    Results: Directly connected my computer to the cable modem, no go, so I do not believe the router is the issue.

     

    So I am at my wits end on this one, this *****, man I hate doing iTunes updates, as there is always some issue when the update iTunes and or iPhones....... **** that Apple...lol

     

    John

  • alfiepercy Level 1 Level 1 (0 points)

    Hi John. I'm having the same problem. I've just put up my own question to see if anyone can help. I just lost genius a few months ago and can't seem to get it back. Have you had any joy yet?