1 Reply Latest reply: Apr 18, 2014 1:56 PM by braden85
Dave n Laura Level 1 Level 1 (0 points)

I Two MacBook  Pros,

when I setup a password on my computer safiri automatically opens Keychain and it asks if I want to gererate a password, and offers to save it.

Keychain is turned on.

 

On My wifes computer when I go to setup a password, keychain dosen't start up and dosent offer to generate a password.

Keychain is turned on, on this computer also.

 

we both are current with Maverick 10.9.2

 

anybody know how to make her computer automatically ask to generate passwords etc?


MacBook Pro (13-inch Early 2011), OS X Mavericks (10.9.2)
  • braden85 Community Specialists Community Specialists (3,660 points)

    Hi Dave n Laura!

     

    If you are having an issue with your iCloud Keychain, you may want to use the troubleshooting steps in the following article to help you address this issue:

     

    iCloud: Troubleshooting iCloud Keychain

    http://support.apple.com/kb/TS4644

    Safari isn't automatically filling in account names and passwords on some web sites.

    Devices using iOS 7.0.3 or later:

    1. Go to Settings> Safari > Passwords & AutoFill and make sure that these two settings are turned on:
      • Names and Passwords
      • Always Allow
    2. Return to your Home screen and open Safari. If Safari is black or dark instead of white or gray, Private Browsing is turned on. Safari doesn't save account names and passwords when Private Browsing is turned on. To turn off Private Browsing:
      • On iPad, tap the the plus + symbol in the upper-right corner of the Safari page, then tap Private in the lower-left corner.
      • On iPhone and iPod touch, tap TS4644_IL_Pages.png in the lower-right corner of the Safari page, then tap Private in the lower-left corner.

    Macs using OS X Mavericks v10.9 or later:

    1. Choose to Safari > Preferences, then click Passwords.
    2. Make sure that that these two checkboxes are selected:
      • AutoFill user names and passwords.
      • Allow AutoFill even for websites that request passwords not be saved
    3. Open the Safari menu and make sure there's not a checkmark next to Private Browsing. Safari doesn't save account names and passwords when Private Browsing is turned on.

    I get a message saying that Safari will not save the password on one of the websites I'm using.Safari will not save or autofill account names and passwords on some websites that request that passwords not be saved. To allow Safari AutoFill on those websites:Devices using iOS 7.0.3 or later:

    1. Go to Settings > Safari > Passwords & Autofill.
    2. Turn on Always Allow. You must have a passcode lock on your device to enable this feature.

    Macs using OS X Mavericks v10.9 or later:

    1. Choose Safari > Preferences, then click Passwords.
    2. Select “Allow AutoFill even for websites that request passwords not be saved”. You must set a screen lock before your Mac can use this feature.

    Thanks for coming to the Apple Support Communities!

     

    Cheers,

    Braden