5 Replies Latest reply: Apr 26, 2014 8:16 AM by sbpowers
HBphotobuff Level 1 Level 1 (0 points)

I recently purchased the Nikon D4S professional DSLR. I am unable to import pictures to iPhoto. Any suggestions?


iPhoto '11, iOS 7.1, Nikon D4S DSLR
  • chattphotos Level 4 Level 4 (1,910 points)

    First, read the manual on connecting to the computer.

     

    Second, make sure the camera is in the right mode for communicating to the computer as a Mass Storage/PC option.

     

    Being that you have USB, Ethernet, and/or Wireless options, if none of those are working, read the manual.

     

    I take it you have a Mac that doesn't have a SD slot built in?

     

    Have you tried using Image Capture?

     

    is iPhoto up to date?

  • sbpowers Level 1 Level 1 (0 points)

    I also have the D4S and experience the lack of ethernet transfer ability. OS X doesn't see any files on the card.

     

    To answer the earlier question about SD card slot on the original poster's laptop, this is a moot point as the D4S doesn't support SD cards. (XQD and CF only)

     

    I can change camera settings via ethernet, so do know that Mac OS X (Mavericks) sees the camera. However, when I try to browse files no filer or folders show up. This seems to be a file system issue: either the file format is not recognized or perhaps the directory structure?

     

    I'm exploring a WIndows 7 VM as a workaround though somewhat reluctant to allocate valuable SSD space to Windows OS just so that I won't have to carry card readers. We'll see how impatient I get. 

     

    Steve

  • chattphotos Level 4 Level 4 (1,910 points)

    Sb, I think the OP abandoned the thread,

    Second, they never said which type of communication they were using.

    Third, what happens when you read the manual for ethernet/USB connectivity?

     

    I state again... with revisions...

     

    Have you contacted  Nikon support about this?

    Make sure the camera is in the right mode for communicating to the computer as a Mass Storage/PC option.

     

    Have you tried USB?

     

    Did you directly connect the camera to the computer's ethernet port, or did you connect it to your wifi router?

  • Terence Devlin Level 10 Level 10 (132,305 points)

    SHooting Raw or Jepg? What version of iPhoto? What version of the OS?

  • sbpowers Level 1 Level 1 (0 points)

    I've now achieved success at my end. Let me describe.

     

    The Nikon D4S uses either USB 3.0 or Gigabit Ethernet to communicate with a computer. It speaks USB without any intervention or configuration on the user's part, it looks like mass storage. Ethernet connectivity requires a bit more configuration. My issue was getting Ethernet connectivity working.

     

    The camera communicates via Ethernet in several manners: FTP transfer to server, HTTP web server, PC communication and Camera Control. Each requires setup both on the camera and other end to work properly. Configuration is mostly done on the camera. It's done pushing buttons therNikon offers a utility - "Wireless Transmitter Utility" - to help with setup via the computer.

     

    I wanted "PC Communication" as it simply pushes the contents of memory cards directly into a directory on the computer that you specify. I began with my 13" Retina MBP, running 10.9.2 and using v 1.3 of Nikon "Wireless Transmitter Utility" which configures the camera/computer to handle IP traffic, wireless or wired. I was planning to directly connect the camera to the MBP (w/o router or switch).

     

    To use the Nikon utility, you need to have both an Ethernet cable and a USB cable. You connect the camera via USB, turn on the camera and launch the app. You choose which type of Ethernet functionality you want to setup and use the app to configure that. About 3 or 4 steps in, the apps will load your configuration (IP address, ports, handshakes, names, etc.) into the camera via USB. That's where I was getting stuck. It would simply timeout.

     

    I said earlier that I knew the connection (Ethernet) would work as I'd set it up manually on the camera. I could get web server (HTTP) comms working but could not get PC Xfer working. This told me that it wasn't hardware, drivers or cabling but something in software.

     

    Last evening I tried the setup again, this time on a MacBook Air. Because the Air had no direct Ethernet connectivity, I connected the camera via cable to a TimeCapsule. The Air was connected wirelessly. I downloaded the Nikon utitility and found a newer version - v 1.5. Upon connecting the camera via USB I was able to get past my previous block and could add/delete configurations. I deleted all of them and began fresh.

     

    Success! The MBA --(wireless)--> TimeCapsule --(Ethernet)--> D4S worked fine. I specified a directory off of root, enabled the transfer on the camera and voila! It streamed the entirety of the CF card onto the computer. I got both RAW and JPEG files across.

     

    I then installed v 1.5 of Nikon "Wireless Transmitter Utility" on my 13" Retina MBP. I connected the camera via Thunderbolt --> Ethernet with similarly successful results. It is now fixed.

     

    As for being able to interpret the .NEF (RAW) files, I cannot say whether or not any Apple software will do so as I use Lightroom.

     

    I hope this helps someone.

     

    Steve