9 Replies Latest reply: Jul 21, 2014 9:40 AM by Motorcycle Michael
Motorcycle Michael Level 1 Level 1 (115 points)

I recently retrieved my beloved old SE/30 from 12 years in (safe) storage. Was working fine when I packed it away and is in great condition - except it won't boot.

 

Symptoms: Bright, well-adjusted raster and moving cursor; no startup tone, no disk icon, goes no further in boot process. If I insert a disk, nothing happens. Doesn't seem to get far enough to respond to keyboard commands either, so I'm really stuck. 40MB HDD spins up, as does the external (whopping!) 1GB SCSI drive. Tried internal 40MB HDD thru external SCSI port = no go. (Only difference was the cursor wouldn't move.)

 

With _no_ HDD attached and nothing in floppy drive, I get same symptoms (above).

 

"Programmers switch" does't help; one blanks the screen for an instant and returns it to same state, the other produces 000000F over 0000013 (which only means "don't do that again" near as I can tell).

 

I found leaking caps and replaced all caps on logic board (incl. C11, the 220mfd to nowhere), new battery, got all drives working, cleaned/reseated all chips/connectors. All that = no change.

 

I have Larry Pina's Dead Mac Scrolls, all 8 pages of the SE/30's schematics, and a growing list of 20+ SE/30 web sites. Hoping the gurus here might have a suggestion or offer the clue I can't seem to find anywhere else. Feels like losing an old friend…..

 

Are the Bourns RC network chips (marked 115-0002 C 558 8943B) at RP2, RP3, RP10 critical to startup as some suggest? Are they the next suspects?

Thanks,

Mike

  • Appaloosa mac man Level 5 Level 5 (4,330 points)

    Mike,

     

    Sounds like you have done an excellent job on research and repairs.  Time to test components and use the process of elimination.  Do you have another Mac that will allow you to look at the hard drives independently?  Do they mount and do they have recognizable software?  Does the RAM work properly in other Macs?

     

    Where are you located?  Please name a large city near you.  If you are in Washington State, we can help you.

     

    I am reminded of buying six SEs from a yard sale.  They all worked but each one had something wrong.  A 'supposed technician' at the store decided that he would take the best items from each SE and combine them into one working computer for his mother.  He proceeded to kill all six.  Sometimes trial and error is the best way to find reliable parts.  Other times it just accelerates the death of multiple components.

     

    Also, post back with what access you have to diagnostic equipment.  Knowing a city might help in finding a user group with an old timer in it.

     

    Ji~m

  • Motorcycle Michael Level 1 Level 1 (115 points)

    Hi Jim, thanks for the kind words and response.

    I'm in N. Cal. near Sacramento.

     

    Another SE/30 would be a great help to be sure. I suppose I could dust-off my old Performa 6300, it has an external SCSI II that _might_ read the old MFS format. But - no display! No shortage of cables/adapters here, I have an old VGA - hmmm.....

    I have 800K floppy drives, but only the one 1.44, and two 128K Macs (turned 512s) that are no help with the SE/30. I also have a SCSI Zip drive (and disks) packed with the SE/30 that might be handy eventually.

     

    But I don't think I'm getting far enough in the boot process to blame drives yet. With no HDD and nothing in floppy drive, I should get a tone and disk icon/question mark, no? Machine has 5MB RAM; I tried removing the four 1MB SIMMs from bank 1 leaving four original 128s in bank 2, reversed banks, tried four 1MBs in each bank, no help (no other way to test RAM). Bad RAM would produce a sad Mac, right? "Mo" (short for Maureen) also has a Diimo board, with/without = no change. Even removed the ROM, result was horizontal bars.

     

    This machine was my workhorse for many years, was always solid as a rock (menubar is burned-in to CRT).

    If the ROM chip somehow went bad, would I still get a solid screen? And how is the mouse/cursor working without any OS/driver?? Then there are the Bourns..... (BTW, I have Pina's book because I used it to troubleshoot Macs back in the day.)

     

    Assuming RAM passes, what's the next step in boot process?

    Thanks again - I'm stumped.

  • Appaloosa mac man Level 5 Level 5 (4,330 points)

    Where has the week gone?  I just noticed that your response has been here for a week.

     

    First off, have you zapped the PRAM?  With all the changes and testing, it would not hurt to give it a fresh look at the hardware configuration.

     

    With the zip disks, do any of them have a system to boot from?

     

    As for no chimes, that is not uncommon. 

     

    You should get the "?" at startup.  If you do not, then the ROM has not finished polling devices and moving on to a boot sequence.  That takes us back to zapping the PRAM.

     

    Got to go, will check back with more ideas later.

  • Motorcycle Michael Level 1 Level 1 (115 points)

    Thanks Mac Man, no hurry here - we're all pressed to the max these days it seems.

     

    I don't get far enough in boot process to allow any keyboard input, but removing PRAM battery should certainly do it. I know both ADB ports are working as the mouse moves on either. Completely stuck here, wondering if replacing ROM SIMM would move things along..... or those Bourns chips?

     

    I have OS 7.5.5 and 7.5.1 on floppies, Zips and hard drives, lots of troubleshooting apps and utilities from back in the day as well as earlier and later Systems. Floppy drive not responding, keyboard not responding, OS has to load Zip driver before Zip drive operates, so..... Really need a second SE/30 I guess.

  • Alexy.C Level 1 Level 1 (0 points)

    You may want to check eletrolytic capacitors on the logic board as they can leak electrolytic fluid ,which is conductive, causing a trip on the board.

  • Motorcycle Michael Level 1 Level 1 (115 points)

    Hi Alexy-

    Yes, been three, done that, replaced all caps. Seems to hang at loading ROMs, not sure what I can do about that.....

  • Alexy.C Level 1 Level 1 (0 points)

    hi michael,

    you may want to check ROM chips- they could be loose or even damaged. I have seen people with similar issues on youtube.

  • spudthemac Level 1 Level 1 (0 points)

    If you still haven't fixed the problem, check this website out: http://www.biwa.ne.jp/~shamada/fullmac/repairEng.html

     

    -Michael

  • Motorcycle Michael Level 1 Level 1 (115 points)

    Thanks Spud, been all over that site and about 20 others.

    Think I need to replace ROM SIMM as it seems to be stopping there. "Mo" (my SE/30) is still sitting here waiting to boot up.... that site has all sorts of valuable suggestions and info (as did Larry Pina's book), but nothing specific regarding my symptoms. I'll be shopping for a ROM chip if I can find one.