1 Reply Latest reply: Apr 18, 2014 11:12 PM by stevejobsfan0123
JWenngatz Level 1 Level 1 (0 points)

I just bought a new iPhone 5S and I need iTunes 10.6.8 or newer to set up my phone like my old iPhone. I currently have iTunes 10.6.3, and when I try and upgrade iTunes from the app itself it says that I have the most current version (but I obviously don't). I tried to download the most current version of iTunes (version 11.1.5) from apple.com but it says that I need version 10.6.8 for that to work. How the **** do I download version 10.6.8?!?!?!?!!? I have a Mac OS X 10.5.8. Thanks!


iPhone 5s, Mac OS X (10.5.8)