3 Replies Latest reply: Apr 25, 2014 6:27 AM by Limnos
fastestr6 Level 1 Level 1 (0 points)

I have a Mac g4 ppc laptop and cannot find what versions of itunes and quicktime it will support. The new itunes will not open and the quicktime will not update. Can anyone help?


Mac OS X (10.6.8)
  • Klaus1 Level 8 Level 8 (45,410 points)

    As you show as running Snow Leopard 10.6.8, which cannot run on a PPC Mac, please confirm what Mac you have and what version of OS X.

  • fastestr6 Level 1 Level 1 (0 points)

    Thanks Klaus, as a first time Mac user on a used Mac I had a tough time finding the OS. Someone told me it was 10.4 and another says 10.6 and finally found that it was 10.5. I was able to download Quicktime 7.5.5 and now itunes is operating smoothly.

  • Limnos Level 8 Level 8 (40,705 points)

    To get more information about your computer, go to the Apple in the upper left corner of any window, then "About This Mac", then "More Info..."  If requested copy and paste the information here but omit the serial number and Hardware UUID (if present).