Previous 1 2 Next 18 Replies Latest reply: May 14, 2014 4:49 AM by needleman_mark
needleman_mark Level 3 (960 points)

Has anyone else noticed weird behavior after upgrading to 7.1.1 - on my 5s its not that the battery is draining quickly - in fact its showin 5 hours 40 minutes usage with 75% remaining - which i find hard to believe


whats weird is standby time equals the usage time but i have turnd off and aback on the iPhone - I even did a hard reset - i have a monitor program which is showing the cpu as mostly idling at 90% or more ( although the monitor probably doesnt know about the M7 chip - it probably doesnt even know about the A7 chip too)


The battery percentage is not going down quickly - it seems to be thr same rate as with 7.1 but i dont believe these numbers


Im going to let the battery drain completely and do a battery calibration - that some times helps after IOS upgrades


But i was wondering if anyone else was seeing this and had any suggestions

iPhone 5s, iOS 7.1.1
  • Grant Hiesterman Level 1 (5 points)

    I am seeing very similar.  Yes.  I read the blog at and did everything there culminating with the trip today to the Genius Bar.


    They did a hard reset.  No help.


    We charged the phone to 100%.  Problem still persisted:  Standby and Usage time were equal.  All apps/pushes/ etc. were turned OFF.


    Then we did a General>Reset.  Problem still there.


    This all began with the upgrade to 7.1.1.  I, too, think the overall battery life is longer now.  Maybe we just need to ignore the Usage/Standby numbers and be thankful our battery is lasting longer.


    It is obviously an unintended glitch in the IOS, not the thousands of users who just began experiencing this strange phenomenom.


    I could do an entire iPhone restore, but not sure if it is worth the 4 hour effort.  None of these issues appeared in my iPad Air with IOS 7.1.1.


    Just find the problem and fix it Apple.  It's not that difficult...and I'm sure you already know the culprit.  Give us

  • Grant Hiesterman Level 1 (5 points)

    Just to follow up;  I did a complete restore from back-up from within iTunes.  Problem remains unresolved.

  • Trevor Jacques Level 1 (10 points)

    I finally found the culprit on my 5S, and it did not need a reset to do it: Set Time Zone Automatically to OFF.


    The trick to finding it was to follow the instructions at OverThought, and discover that with all the other items noted in the guide, the problem of drain persisted with no apps open, no apps using background app refresh or location, and mail set to fetch only. That is, with EVERY app set to not use CPU in the background, drain continued, so it had to be iOS. On looking through the General settings, I had previously set everything to off, apparently with the exception of the auto time zone. Switching it off stopped the CPU from thrashing when the iPhone was in sleep. When it was ON, the iPhone used as much CPU in sleep as it did in wake time.


    I did turn Time Zone Automatically back on, to find that the 5S continued to behave well, but YMMV. FWIW, I don't think I even had to fully power-down the 5S to cure the problem. Please note that this problem occurred both with and without a SIM in the 5S, but the cure was done without a SIM in the 5S. Perhaps, there's some weird interaction with the SIM that messes up the code for automatically setting the time zone. I tested by putting the SIM back in and, say I knocking on my head, it seems to still be 'cured.'


    So, for all of you with problem battery drain, maybe the cure is to turn OFF setting the device's time zone automatically, and, possibly, after testing there's no battery drain, per the above link, to turn it back on.



  • Grant Hiesterman Level 1 (5 points)

    Very cool and nice thought process.


    I followed everything you said, with and with a SIM and it did not solve the problem.


    I have done a hard reset, a complete erase and restore, and the Time Zone turned to "OFF" with and without a SIM.


    Last night I ran the battery down to "0" then recharged to 100%.  Usage and Standby Time yet remain identical.


    Now the good news, I don't seem to be losing any overall battery life between charges.  For now I guess I'll take the ostrich approach and stick my head in the ground and pretend there is no "Usage since last full charge" available to view on my iPhone 5.  Then I would not know my iPhone seems unable to rest when all known applications and services are turned "OFF."


    Keep in mind, battery drain has always been discussed with every IOS released ever.  But NEVER has Usage and Standby Time remaining identical since the release of IOS 7.1.1. 


    The logical inference is that it is connected to or a direct effect of something done or not done when the IOS was compiled.  They'll find the specific issue and fix one of these days.

  • Trevor Jacques Level 1 (10 points)

    Interestingly, I just put the 5S into sleep, and removed the SIM. After that, the standby and main usages were the same, again, for about 45 minutes until I took a peek at the usages. So, I switched the auto time zone off and then on again. Now, the standby and main usage numbers are properly different. Something's CERTAINLY up with auto time zone and the SIM.


    I'm not about to go through all the permutations of 'phone on/sleep/standby when I take out/put in the SIM, along with the auto time zone on/off, just to tell Apple the particular combination that is reproducible.


    For my purposes and for now, I know how to kick the 5S into proper CPU usage in standby, if it starts misbehaving again.


    FWIW, the good thing about charging fully, is that it's easy to test if there is a difference between Usage time and Standby time. Whenever these two times are the same after putting the iPhone into standby and then pulling out the charging cord, you have a problem.

  • Lawrence Finch Level 7 (34,035 points)

    Grant Hiesterman wrote:


    Keep in mind, battery drain has always been discussed with every IOS released ever.  But NEVER has Usage and Standby Time remaining identical since the release of IOS 7.1.1.


    That part is NOT true generally; it may be for you, however. You will find thousands of posts going back over 6 years describing the problem of Usage and Standby time being equal. What this means is that there is an app stuck in a loop that is not allowing the CPU to go to sleep.

  • Trevor Jacques Level 1 (10 points)

    In the caseof my 5S, that app is clearly Auto Time Zone setting.

  • Grant Hiesterman Level 1 (5 points)

    Lawrence, you are correct.  I am wrong.  I forgot all about that.  So goes the aging process at times.


    Out of curiousity, how were the issues fixed/resolved other the past?  With IOS updates? Other?


    You are also correct in your observation about me personally.  I've owned every phone but the 5S.  The past two weeks are the only time I personally have ever seen this issue...and I do check and montior these numbers almost daily.


    Do you or Trevor have a CPU monitoring app you believe is a quality application?


    Kind regards,


  • Trevor Jacques Level 1 (10 points)

    There's no need for a monitoring app. There are two ways to check usage. Either note down the two numbers and then put the iPhone to sleep for, say, ten minutes. Then, wake it and check the numbers. If both have increased by ten minutes, you have a problem with a rogue app (or Apple's Auto Time Zone) running the CPU while the iPhone is asleep.


    Alternatively, and more easily, charge up the iPhone to 100%, put it into sleep/standby, and then pull out the charging cord. Wait a number of minutes and revisit the usage numbers. If they are identical, you have a problem. If the Standby usage is high and the Usage is low, say a minute or less, you're fine.


    It's not rocket science and takes all of ten minutes to do the test.

  • Trevor Jacques Level 1 (10 points)

    Maybe only five minutes.

  • Grant Hiesterman Level 1 (5 points)

    You've seen all my posts Trevor and know I've done as you suggest.


    I would appreciate your insight in how I determine/find the rogue application...b/c it's not my time zone button.


    If you want to shoot me anything via a side channel:

  • Lawrence Finch Level 7 (34,035 points)

    Grant Hiesterman wrote:


    Out of curiousity, how were the issues fixed/resolved other the past?  With IOS updates? Other?


    The problem has always been an errant app that got stuck in a loop. It can happen any time, but is more likely to happen right after an update. My hypothesis is that the update process suspends running apps, and sometimes after the update they "lose their place" and spin their wheels trying to find it. (It's easier to say it that way then to talk about race conditions.) What will frequently fix it is to run the battery all the way down until the phone shuts off. This terminates all processes, even those that cannot be killed from the Quick Launch screen.


    You can also try to find the app; if it's email turning off any Push email accounts, rebooting, and turning them back on will frequently fix it. If it's a 3rd party app killing all apps in the Quick Launch will frequently fix it.


    Sometimes just turning off the phone for a few minutes will fix it.


    Restoring the phone as new will usually fix it, but restoring from backup may not, because the app state may be preserved in the backup.


    It really just a matter of trying things like these one at a time. One of them will work.




    Do you or Trevor have a CPU monitoring app you believe is a quality application?

    I've tried several, and haven't found any that I like. I like Trevor's answer.

  • Trevor Jacques Level 1 (10 points)

    All I can suggest is to go through the Settings and turn off anything that looks even vaguely like time- or location-related, for all apps. Then make sure that iOS is not doing anything in the same vein, which is how I came by the Auto Time Zone problem on my 5S. It's really just a process of elimination. Once everything is, in theory, not using services when on standby, the usage figures should start to differ. If they do not differ, you've likey missed something.


    It took me a while to realise that Auto Time Zone would be searching either by cell, wifi, or BT to determine the current time zone. Apparently, in my case, it can get stuck in some subroutine, constantly using the CPU, even when the 5S is asleep. The OverThought guide really does tell you how to know if you have a problem.


    If you truly have turned off EVERYTHING that might even blip in standby mode, and you still have a rogue process chewing up the CPU in sleep, I'd take the 'phone to your nearest Apple Store.

  • Grant Hiesterman Level 1 (5 points)

    Finally got it fixed!  Did everything suggested twice in Overthought and in this discussion group.  Two trips to the Genious Bar at Apple.


    They erased then entire iPhone and data; then I went home and spent 4 hours setting it back up as new.


    All works perfectly now...just a bit time consuming...but glad it works properly.  There are still a few app login credentials I need to enter, but that will come in time.


    Thanks for all the positive input and feedback.

Previous 1 2 Next