6 Replies Latest reply: Sep 10, 2014 2:40 PM by herlitski
xMatter Level 1 Level 1 (0 points)

We are using a SonicWall firewall at work and no user cannot access the AppStore using iOS 6 or AppleTV. iOS 7 devices seem to work fine. The only common denominator is the SonicWall. I could not even activate a newly purchased AppleTV within the network, had to connect to my mobile hotspot to activate.

 

I have whitelisted all 4 of Apple's servers within the firewall and the 2 ports were already opened from other internal applications. What am I missing that needs to be done to allow access for activations and the downloading and using of apps?


iPhone 4S, iOS 6.1.3
  • norm123 Community Specialists Community Specialists (4,885 points)

    Hello xMatter

     

    Check out the article below to know all the ports that are used by Apple for its services and stores.

     

    Well known TCP and UDP ports used by Apple software products

    http://support.apple.com/kb/HT6175

     

    Regards,

    -Norm G.

  • xMatter Level 1 Level 1 (0 points)

    This was not an issue last year and all ports and sites including versign are white listed.

  • Templeton Peck Level 9 Level 9 (59,380 points)

    monitor your firewall for activity from the device's IP address when you attempt to connect or contact Sonicwall as the issue is clearly stemming from the firewall and not the phones or TV

  • xMatter Level 1 Level 1 (0 points)

    I see connections to UDP being dropped around the time I try to access the App Store. I have wrote a post within the sonic wall forum as well, just posted here to see if others encountered this issue.

  • ShakielB Level 1 Level 1 (0 points)

    Hi XMatter

     

    Did you have any luck with the above mentioned issue. I have the same issue on my Sonicwall.

    My firewall is block all traffic to the Deploy.akamiatechnologies.com which is the apple updates links.

    However i did not constitute these changes on the firewall, as it started around the same time as yours.

  • herlitski Level 1 Level 1 (0 points)

    I had this same issue with my SonicWall today.  I fixed it by:

     

    1) Logging into my SonicWall Admin

    2) Clicking Security Services

    3) Application Control

    4) Scroll down mid-page to the drop box under 'App Control Advanced', labeled 'View Style - Category'

    5) Drill into that drop box, and select 'Multimedia'

    6) You will now see an alphabetical listing of known applications

    7) Scroll till you see Apple iTunes, then click the configure link to the right of Apple iTunes

    8) A pop-up window will appear with the advanced options for said App

    9) The 3rd option down labeled 'BLOCK', drill into that drop down box and select 'DISABLE'

    10) Click Ok

    11) Do this for the other Apple Apps that you frequently use

     

    Following these steps solved my problem today.  After monkeying around with port setups for a substantial amount of time, I decided there had to be an easier way.  And sure enough, there was.  I hope it works for you too.

     

    -a