7 Replies Latest reply: Apr 25, 2014 9:16 AM by Dr.Mersal
Dr.Mersal Level 1 Level 1 (0 points)

Hello :)

 

I just finish your answers about tackpad problem and I tried all your suggestion.

 

The problem is

 

I had a mid 2009 macbook pro 13 inch with Leopard 10.5.8 OS

Yesterday I mad a decision to erase my HD and reinstall the OS again ( for no purpose ... Only I didn't do this before so I needed to re frish my Mac and would think for system upgrade )

I had the OS installing DVD with version 10.5.7 ( older than the original version on my Mac )

During the installation ; I noticed that the tackpad don't respond to any click .. Only move around normally with my moving finger but no response for clicking .. I assumed that this is normal during the installation process and will be OK after the finish .. So I used keyboard to complete the process

 

I realized after finishing that the problem still present ... I assumed that that is a software problem due to the older version I have or something ... So I reinstall the OS again but with the same problem

 

I searched the web for a solution and I noticed that a lot of people had the same problem when the upgrade the system ( that is similar to what I have )

 

I am afraid that it would be a hardware problem especially I live in a place with nearly no Mac expert or stores

 

What should I do ?!!!!!!!

 

Take in consideration that : the click was normally functioning before I reinstalled the OS .... Also I tried every solution from restart and SMS reset but with no response ... I didn't use a USB mouse yet and don't prefers to remove the battaries ...


MacBook Pro, Mac OS X (10.5.7)