12 Replies Latest reply: Jan 19, 2016 12:50 PM by kemelinux
Lucas Metcalf Tobin Level 1 Level 1

iCal will no longer sync with my work Exchange calendar.

 

I have deleted and added the account several times, but that is not working.

 

I was getting messages about specific events not being synced with the server, but now I get the following message:

 

"Calendar can't refresh with the account "RPD Exchange"

There was an error attempting to send your changes to the exchange server"

 

Any ideas?

 

Thanks.


MacBook Air, OS X Mavericks (10.9.2), 4 GB 1333 MHz DDR3
Reply by GiantBrain on Feb 20, 2015 9:31 AM Helpful
Just hit this issue, with 10.10.2 Yosemite myself.  Simple to fix.  First Close iCal.  Then go to system preferences and open internet accounts.  Selected the Exchange account and turn off calendar.  Closes System preferences.  Now, from the finder, goto the GO menu, and hold down the option key.  While holding down the option key, you will see "Library" appear.  Click on this and it will open a finder window.  Then go to directory named Calendars. You will see a file called, Calendar Cache.  It should be a big file, depending on how much you have stored on your ical, maybe around 5 to 11 megs.  Move it to the trash can.  Then restart iCal.  iCal will crash the first time you open it due to the missing cache file.  Just hit ok and reopen it.  At this point iCal will reload all you accounts.  This can take a couple of minutes depending on how much info is there.  Most of the time you Exchange account will reload by its self, but only after all the iCloud events are rebuilt.  After iCal is back up and running go back to System Preference and make sure Exchange calendar is on.  Most of the time it will turn on by it's self.  Best of luck.

All replies

  • TechInput Level 1 Level 1

    Somebody found a solution?

  • mbressan Level 1 Level 1

    This is probably better than nothing... I ended up fixing this after lots of trial & error. Enabling and disabling Contacts, then enabling and disabling Calendars in my Exchange Internet Account seems to have done the trick.

  • jcfluhr Level 1 Level 1

    Anyone find a fix?

  • IMRAN Level 2 Level 2

    I cannot believe I am running into so many separate issues since moving to Yosemite. And some of these are common since several years.

     

    Yosemite Mail kept crashing (several threads on that topic) but Calendar showed my MS Exchange items just fine. The only way to fix Mail was to delete all accounts and add them back in. Took a long time to get all the messages synced, but Mail stopped crashing. But too early to celebrate because now Exchange Calendar is not showing up in Yosemite Mail. (It appears fine on iPhone, iPad, etc.) . The error is:

     

    There was an error attempting to send your changes to the exchange server.

     

    Incredibly frustrating upgrade experience.

     

    Imran

  • Fernando @ PSAV Level 1 Level 1

    Same of you.

     

    Calendar can’t save the event “prueba” to the Exchange server.

    There was an error attempting to send your changes to the exchange server.

     

     

    BLA :::  BLA :::: BLA

     

    HELP. PLS

  • GiantBrain Level 1 Level 1

    Just hit this issue, with 10.10.2 Yosemite myself.  Simple to fix.  First Close iCal.  Then go to system preferences and open internet accounts.  Selected the Exchange account and turn off calendar.  Closes System preferences.  Now, from the finder, goto the GO menu, and hold down the option key.  While holding down the option key, you will see "Library" appear.  Click on this and it will open a finder window.  Then go to directory named Calendars. You will see a file called, Calendar Cache.  It should be a big file, depending on how much you have stored on your ical, maybe around 5 to 11 megs.  Move it to the trash can.  Then restart iCal.  iCal will crash the first time you open it due to the missing cache file.  Just hit ok and reopen it.  At this point iCal will reload all you accounts.  This can take a couple of minutes depending on how much info is there.  Most of the time you Exchange account will reload by its self, but only after all the iCloud events are rebuilt.  After iCal is back up and running go back to System Preference and make sure Exchange calendar is on.  Most of the time it will turn on by it's self.  Best of luck.

  • Wayan_V Level 1 Level 1

    Thanks - clearing Calendar cache worked for me.

  • Joel Forman Level 1 Level 1

    This worked like a charm for me too.

     

    Maybe some kind of corruption in the calendar Cache.

     

    Thanks for the advice!

  • Macphaloskeptic Level 1 Level 1

    Thanks. I tried the fix suggested by GiantBrain and had a number of different calendar cache files so deleted all of these with the same result, "There was an error attempting to send your changes..."

     

    So following your approach mbressan I went back into Preferences>Internet Accounts and disabled Calendar, Reminders, Notes and enabled Contacts (the latter being disabled due to large number of contacts on Exchange server). I then opened iCal and closed it. I enabled Calendar and disabled Contacts and reopened iCal. The error was finally gone. I repeated the step of closing iCal and enabling in turn Reminders and Notes, each time expecting the error might return. However all is well. So many thanks.

  • tpisales Level 1 Level 1

    I have done all of this and I am still getting the same error.  The exchange server I am trying to connect to is 2007.  I am on version 10.10.5 on my Mac Book

  • ctsak Level 1 Level 1

    Thank you.  Your suggestion helped me fix my calendar issue.

  • kemelinux Level 1 Level 1

    I got this error since recent and in my case it seems to be related to Lync meeting requests that were made in background. Last week I pressed the "meeting" icon repeatedly but nothing seemed to happen. And since then my calendar no longer synchronises. Just now I configured my Outlook for the Exchange server and noticed several empty "New meeting requests" in "my local calendar". These meeting requests were never synchronised to the Exchange server and they could be the cause of conflict resulting into the "There was an error attempting to send your changes to the exchange server." messages. In Outlook I deleted all these meeting requests, emptied all the trash folders, synchronised with the Exchange server, deleted the Calendar folder,... but this did not fix the issue. But I am certain that this is the cause of my synchronisation issue.