Previous 1 2 Next 28 Replies Latest reply: Apr 29, 2014 1:02 PM by turbostar
ForeverShine Level 1 Level 1 (0 points)

Ok, for the past few days i have done alot of attempts at finding an exact answer to my problem, but to no avail. So hopefully as i describe it here , it could help get me pointed in the right direction.

 

I have a late 2009 imac, with Mavericks installed. I have tried installing windows 7 both 32 & 64, i get the partition done in bootcamp, reboot process etc , gets to windows install screen, but now when it searches for its first drivers it cannot find it and i am forced to exit out and go back to osx etc, and start researching another way to solve the problem.

 

I have read there is a problem with downloading the apple support software thru bootcamp, so ive done it from the website directly. Am i correct with the following here ,-- These files put on the thumb drive, are NOT the drivers for windows, they are to be installed after windows is installed. Right ?

 

Recently i read windows 7 cant be put on mavericks, but that was a thread related to a different computer and year than mine. So that lead to even more confusion. So apologies, but i do hope i can get a simple way to get this completed. I appreciate your time & help in advance.

 

--Edit -- I realized i posted this here , and it should of went into the bootcamp section,  sorry.


iMac, OS X Mavericks (10.9.2), Bootcamp - windows 7 install
  • turbostar Level 4 Level 4 (2,920 points)

    This situ is posted about once a day, so maybe this forum search is partially to blame

     

    Are you using a usb3 device? Use usb2 only

     

    Have you made any mods to your machine

     

    If you have an internal optical drove, you must use that for the windows disc

     

    Disconnect all USB devices except kb, mouse and usb2 key for windows support software

  • ForeverShine Level 1 Level 1 (0 points)

    hey thanks, yea ive tried various searches as well. But to answer your questions.

     

    -Usb2 , (formated to Fat32)

    -No Mods

     

    (to make it easier ill copy my specs here)

    iMac 27-inch, Late 2009

    Processor  2.66 GHz Intel Core i5

    Memory  8 GB 1067 MHz DDR3

    Graphics  ATI Radeon HD 4850 512 MB

    Software  OS X 10.9.2 (13C1021)

     

    Macintosh HD:

     

      Available:    878.61 GB (878,613,200,896 bytes)

      Capacity:    999.35 GB (999,345,127,424 bytes)

     

     

    -yes i have internal optical drive, and i get to the windows 7 very begining of windows7   install part, choose the hard drive partition of where to install,  but then, it asks to search for drivers, & it cant locate, I can see the USB drive while there , but it just doesnt find the drivers.  And i cant continue windows 7install.

     

    -yes everything disconnected except KB, USB , Mouse,

  • turbostar Level 4 Level 4 (2,920 points)

    So far so good, how did you get your current disc

     

    You can burn another windows disc, see here, note look at the very last few posts he was burning them the wrong way

     

    https://discussions.apple.com/thread/6125899?tstart=0

  • ForeverShine Level 1 Level 1 (0 points)

    We have an iso here on an 8gb usb, Windows 7 32bit,  I burned it via, disk utility, > burn, > find file on the usb, and so on.

    The file is a legit file, if that is what you are wondering. OR is it possible the burn or file is corrupt thats why it wont find the driver.

     

    But if the file was burned incorrectly, i wouldnt be getting to the windows install then would i ?

     

    - As checking your link, i am downloading another copy for windows 7 , i am unaware if it must be 32 or 64, so while i await your response, i will just download both =0)

  • turbostar Level 4 Level 4 (2,920 points)

    Your disc seems fine but just isolating variables, if your machine is truly a late 2009 (double check) you can install 64 or 32

     

    http://support.apple.com/kb/ht5634

  • turbostar Level 4 Level 4 (2,920 points)

    Before you try again, restart the machine and do a pram reset

     

    Run bca again, see if you get an option to delete windows, if so take it

     

    Open disk utility and make sure you're back to 1 partition

     

    Then repair permissions twice

     

    Then run bca again with the new disc, you can skip the DL windows software get it instead at the link in my last post

  • ForeverShine Level 1 Level 1 (0 points)

    I have actually ran bca again and removed windows, as well as tried reinstalling again. =0/ And can confirm it did go back to 1 partition (OSX mavericks),

     

    I have not tried the repair permissions, will try that now ,

     

    ... But i originally was unable to find, the support software via apple, so i had to untick the box in order to just create the partition annd attempt to install windows. So i was aware of that site,

     

    So now , i will try again with this current software, which is for 32bit.

    Boot Camp Support Software 4.0.4033

     

    I was under the impression that this software would be installed after windows finished installing. I will be backin a few, hopefully with good news.

  • turbostar Level 4 Level 4 (2,920 points)

    Ok so you're trying 32 bit

     

    Yes, those drivers should be the first thing you do after windows, hopefully is installed

     

    Don't overlook the pram reset, do that then when you boot into OSX repair the permissions

  • ForeverShine Level 1 Level 1 (0 points)

    Ok,  I am  fixing permission now.

     

    But if the bootcamp support software is the first thing AFTER windows..  This wont help me now then

     

    I get to windows setup , thats not the problem, problem is when it looks for drivers to continue the windows setup, it cant locate any, so nothing from windows actually installs, Im forced to reboot back to osx.

     

    -Edit, i am still in process of fixing permissions,  and will reset pram before trying to run bca again.

  • turbostar Level 4 Level 4 (2,920 points)

    I understand where you are, correct those drivers from the apple site shouldn't be the root of your current issue

     

    Ok, I've never tried the pram after the permissions, so to be safe, after the pram restart, repair permissions again

  • ForeverShine Level 1 Level 1 (0 points)

    Ok we have progress, I succesfully have installed Windows onto the partition. Seems as if the resetting of pram, or the fixing of permissions, is what helped me out.  Must of been , because that is the only thing ive done different since my first failure of install. (back when i didnt even have the support software)

     

    Problem is , the screen remains black after a few reboots & "Starting windows" icon etc. And i can hear the iMAC wind down and get quiet few seconds into the black screen. Mouse light remains on ,

    I restarted 2x, and same response

     

    I think i remember reading , this issue was because the apple support drivers are not installed,   So im sure you know my next question will be..... How do i install that. I assume some kind of cmd line entry.

     

    (Btw turbo, i appreciate the troubleshooting as well, double check etc. I know some get aggravated at it, but i understand the importance and just want to thank u again ahead of time for ur help . )

  • ForeverShine Level 1 Level 1 (0 points)

    Ok i am about to get some sleep. tried to edit my previous post but seems to be to late.

     

    Still gets stuck on the black screen.

    I tried booting back to the disk, and doing repair my computer, and load drivers.

    But i am clueless as to which driver to open or install.  setup.exe dont run from there either.

     

    I previously read as well, there may be conflcting issue with my dual monitor ?

    (i have not had it plugged in since prior to resetting my pram, and getting windows installed,  and i wont plug it back in until i hear from u tomorrow.)

     

    Good nite, ill be back in afew hours

  • turbostar Level 4 Level 4 (2,920 points)

    CHECKLIST

    • use only a +8gb USB2 flash drive
    • have you made any modifications to your mac
    • if you have/had an internal optical drive, you must use that for the windows installer or see if this (google usb boot camp hack) works
    • disconnect ALL devices except kb, mouse

     

    STEPS

    • open boot camp assistant, see if have an option to delete windows, if so do it
    • pram reset
    • open disk utility, confirm you're back to 1 partition (‘mac HD’ unless you renamed it) then repair permissions TWICE
    • dl a new windows ISO
    • if you have an optical drive - create a new bootable ISO disc
    • if you do not have an optical drive, insert your usb flash drive
    • open boot camp assistant and choose all options making sure you used the new ISO

     

    if you get an error that the windows support software is unavailable, manually dl it here, put it on your USB2 drive and install by clicking setup.exe after windows is installed

    http://support.apple.com/kb/ht5634

     

    w7 ISOs

    http://techverse.net/download-windows-7-iso-x86-x64-microsofts-official-servers/

     

    bootable ISO disc or google for other walkthroughs

    https://discussions.apple.com/message/24838470#24838470

  • turbostar Level 4 Level 4 (2,920 points)

    few things

     

    great, glad it worked can you mark my recent checklist post as the solution (green mark), i'll redirect others back to this solution

     

    yes, do not reconnect anything back at this point until windows is working

     

    this question is key maybe why it isn't loading, after windows installed and you got to the desktop, windows told you to restart again, right, but gave you an option to restart later? iirc, you should have clicked setup.exe before running that restart.

Previous 1 2 Next