2 Replies Latest reply: May 1, 2014 1:14 PM by Linc Davis
Gunilla Mateus Level 1 Level 1 (0 points)

In the last 3 days, after I wake up my iMac the wi-fi internet connection disappears.  I can see my network and it shows a strong signal but am told that I cannot get a connection.  After re-starting the situation remains the same.  Normally after I switch off the modem the signal and connection return to normal...

Yet all my other devices, iPhone, iPad continue to have signal and connection.

What could be wrong?  Anyone can tell me?


iMac 24", Mac OS X (10.7.1)
  • Paul_31 Level 6 Level 6 (13,050 points)

    Perhaps JAHelms suggestion in this thread may help - seems to work for quite a few that have tried it:

    https://discussions.apple.com/thread/4342982?tstart=0

     

    If that doesn't help, here are a few more general trouble-shooting suggestions:

    http://osxdaily.com/2012/11/30/resolving-stubborn-wi-fi-connection-problems-in-m ac-os-x/

  • Linc Davis Level 10 Level 10 (146,960 points)

    Test after taking each of the following steps that you haven't already tried. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved. Make sure the box marked

    Remember networks this computer has joined

    is checked.

    2. Follow the instructions in this support article under the heading

    Symptom: After restarting or waking from sleep, my computer might not connect to the Internet

    3. Reset the PRAM.

    4. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    5. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    6. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    7. Repair permissions on the startup volume.

    8. Turn off Bluetooth and test.

    9. Reset the System Management Controller.

    10. This step shouldn't be necessary, but has been advised by Apple Support in some cases, apparently as a workaround for a bug. Open the Energy Saver pane in System Preferences. If applicable, click the padlock icon in the lower left corner to unlock the settings. Enter your administrator login password when prompted.

    Select the Power Adapter tab and uncheck the boxes marked

    Wake for Wi-Fi network access

    and

    Enable Power Nap...

    if present. Then, if the computer is a MacBook, select the Battery tab and uncheck

    Enable Power Nap...

    11. Reinstall OS X.