2 Replies Latest reply: May 2, 2014 8:35 AM by Definitely not a ginger
Definitely not a ginger Level 1 Level 1 (0 points)

Soon after the last software update, I noticed that Facetime & iMessage weren't working. I signed out of them and tried to sign back in (all info entered was correct) but it didn't work. So I changed my Apple ID password and tried signing in with that. But now, not only am I unable to sign in, I am unable to sign out of my previous account. Neither password works. When I try, it says "Verification failed. The request timed out." This has been going on for about a week now.

 

The "Erase All Content and Settings" function won't work. I can't do it from my laptop because it says I need to shut off the "Find My iPod" option, and in order to do that I need to sign in with my Apple ID.

 

Soo.. what's going on here? I know now (mhm, of course, NOW I know this) that you're supposed to sign out of everything with your Apple ID before you change it. Is that the issue? Is it my internet? Is it Apple? And how can I fix it?


iOS 7.0.4